Mitsubishi 3000GT & Dodge Stealth Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
183 Posts
Discussion Starter · #1 ·
I did sort through all the posts, but didnt find any help.

I recently got my car back from the body shop, and my ECS light flashes "sport". I went around and checked all the connectors and all the wires are good and intact. Is it possible that one of the struts was damaged and thats why it is blinking?

since its blinking "sport" is that the mode it is in? I got sick of the flashing so i disconnected the computer, does this hurt anything?
 

·
senior member
Joined
·
1,054 Posts
Disconnecting the computer wont hurt ,but why was the car in the shop ,could the wires been disconnected or put back on wrong ? I had compoletely worn out struts and the lights never blinked so i dont think thats the problem . when the car is rolling and you hit like a pot hole or railroad tracks does the car feel like you are losing control in any of the tires ? if so then i would say your struts are just bad or worn .my 2 cents good luck
 

·
Paying Member
Joined
·
481 Posts
My RT was blinking on 'sport' mode. Wire/connectors were good.
Anderson Mitsubishi ran a diagnostic, said the strut actuator was bad, not sending signal to ECS.
They were probably right, but WTF do they know (long story)...
I disconnected the ECS computer, installing KYBs. Struts are trashed...
Disconnecting computer won't hurt anything. The computer just doesn't receive any signals from your struts.
When ECS doesn't get signals from struts, suspension defaults to 'sport' mode.
 

·
Registered
Joined
·
183 Posts
Discussion Starter · #4 ·
Thanks for the info guys.

My car was in the shop because i messed up the right rear wheel when i hopped a curb one rainy night in september, which happen to be friday the 13th. Coincidence i think not!
IT was pretty bad and they had to redo alot of the rear suspension, that is why i was thinking it might be the strut.
But ive been driving my car for about a month now, and it feels the same as it use to be, but i want to get the ecs working again.

I will try to run the diagnosits and see what comes up
 

·
Registered
Joined
·
162 Posts
I was wondering if anyone can help me. I hit the ECS button on mt stealth es and the sport light comes on but I cant feel any differencs. I had no idea that you were actually supposed to feel the difference between sport and regular. I figured it was just somthing to sound cool... hehehhehhehehe. Why might my ECS not be working?
 

·
Registered
Joined
·
323 Posts
my sport light is blinking too. i got my car lowered and had new struts put in so i think maybe because they are not the factory struts the computer doesnt recognize them so the light comes on. i dont know for sure but id like to get it fixed.
 
1 - 7 of 7 Posts
Top