Mitsubishi 3000GT & Dodge Stealth Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1,347 Posts
Discussion Starter · #1 ·
I was wondering if there is a fuse....or what...

I hadnt driven in a few days......It had been covered in snow....I got it all off...and the wipers wouldnt work....back won started too....but then it died as well......I thought it was because there was to much snow on back window.

Anybody have any ideas? I had a buddie tell me on some cars they can become disconnected...is this the case?
 

·
Premium Member
Joined
·
9,023 Posts
They don't get disconnected, is likely a fuse of some sort. If intermittent wipers die, it is likely the switch on the stalk near steering wheel, but if completely fails, is probably fuse. I've got two motors and both work ok, one on car now only seems to work at 2 speeds, my old one had 3 speeds. I plan on putting the old one back on soon to see if it still works ok. I took it off thinking intermittent was on the motor, but is actually a relay in the stalk.

You can unplug the rear wiper, but you have to take the panel on the underside of the trunklid off to do so. Connector snaps together so is doubtful it would come unhooked.

LW
 

·
Registered
Joined
·
1,347 Posts
Discussion Starter · #3 ·
Hmmm....Ill have to try switching the fuse out. Anyone know what type fuse Ill need? I have the manual somewhere....hopefully I can locate it!

Yeah it was wierd....they had been working fine....didnt run the car for a few days.....and I try them and nothing!
 

·
Here Since 2000
Joined
·
3,707 Posts
Jamieryan said:
.

Anybody have any ideas?

Bad switch
bad contact
no contact
bad relay
bad motor
wire pinched off somewhere shorted out
blown fuse
blown inline fuse
harness from the motor became disconnected
Someone played a dirty trick on you and removed your wiper blade altogether

hell I don't know I don't think anyone will be able to tell you the answer only offer suggestions.

I suggest you get a manual and start thumbing through it more ideas and suggestions and start troubleshooting;)
 

·
Registered
Joined
·
1,347 Posts
Discussion Starter · #6 ·
No need to post again! I was following! :)

Yeah...my lazy ass doesnt want to sit out in the 15 degree weather and try to figure it out! Guess Ill have to try a few things...then have mitsu check it out!
 
1 - 6 of 6 Posts
Top