Mitsubishi 3000GT & Dodge Stealth Forum banner

21 - 40 of 40 Posts

·
...550WHP Club...
Joined
·
3,049 Posts
Discussion Starter #22
I have my BOV at the same spot as yours and it sounds the exact same(loud and annoying as shit) as when I had it in the stock location.

Although i do get some serious fluttering in its current location distance is no factor.

If anything it is louder to me now.
Hmm, I wonder if my BOV is just shitty. IS there a way to adjust the BOV's to make em louder? I have the screw just about all the way out. Is the bad? I screwed it in most of the way once and it about blew my radiator up. lol had to replace the upper radiator hose.
 

·
...550WHP Club...
Joined
·
3,049 Posts
Discussion Starter #23
So, can you add inserts or repair them or what? Do I have to buy a new one?

Does anyone have a used one that still works? I want a loud one :(
 

·
Misanthropic Mythslayer
Joined
·
1,418 Posts
Have you tried opening the hood and have someone rev the engine, to see if you can hear it at all? It may simply be in a place that's too noisy/muffled to hear it.

I'm not too familiar with the HKS...is it open atmosphere or closed? If it is closed atmosphere it probably won't be so loud.

As long as it works, do you really need to hear it, or do you think everyone else on the road has to hear it?

If it's working fine, then all you have to do is get one of these,
much cheaper than replacing an otherwise perfectly functional BOV:

BOV NOISE MAKER

:D
 

·
...550WHP Club...
Joined
·
3,049 Posts
Discussion Starter #25
Have you tried opening the hood and have someone rev the engine, to see if you can hear it at all? It may simply be in a place that's too noisy/muffled to hear it.

I'm not too familiar with the HKS...is it open atmosphere or closed? If it is closed atmosphere it probably won't be so loud.

As long as it works, do you really need to hear it, or do you think everyone else on the road has to hear it?

If it's working fine, then all you have to do is get one of these,
much cheaper than replacing an otherwise perfectly functional BOV:

BOV NOISE MAKER

:D
What the hell is that?
 

·
๏̯๏
Joined
·
1,396 Posts
You probably running low boost or wastegate pressure. Mine was annoyingly loud (although I do have authentic HKS specifically made for 3S) so I removed the whistle thingie. Now my car moos like a cow :D
 

·
Registered
Joined
·
11 Posts
Hi, as somebody else mentioned in a previous post, a close loop system is a lot quieter than an open loop system. I run a td04 13g setup with a Greddy type-S on my sl. It will hold about 17psi up to redline and is as quiet as a ghost. If I were to run the bov open atmosphere, it would be loud and I would have to make even more modes due to the maf sensor being located before the bov. Venting to atmosphere is indeed louder, but do it wrong and you may burn rich on heavy shifts, offset your idle, and probably throw off maf sensor readings for more severe problems... Hunt around 3si some and you can find some threads to go open loop if you like. It's a pretty simple process and will probably fix you silence problem. If you are running to the atmosphere, then there is something wrong.
 

·
...550WHP Club...
Joined
·
3,049 Posts
Discussion Starter #30
I dont understand what atmosphere and open/closed loop?
 

·
...550WHP Club...
Joined
·
3,049 Posts
Discussion Starter #33
I believe so
 

·
Registered
Joined
·
4 Posts
Hey, I have an HKS SSQV and it's loud as hell. Sometimes in different weather conditions it is very soft though. Maybe a humidity thing or something. But even if yours is a knock off it should still be decently audible. I would suggest checking your vacuum line to your BOV to see if it's leaking. That will shut it up right away. BTW...mine is half buried down deep so I doubt the distance is an issue.
 

·
Premium Member
Joined
·
790 Posts
Check the vac line going to the BOV. it might be ripped torn somewhere. My SSQV makes noise at 1 PSI. you should be able to hear it, definitely.

make sure you check that line... Theres a line coming off a nipple at the top of the BOV and it HAS to be connected to a vacuum source. Check, the line and make sure its not torn anywhere. It happened to me once, and I pulle the line out, and it was torn.
Thats the first thing you should check.
 

·
...550WHP Club...
Joined
·
3,049 Posts
Discussion Starter #37
wow, i fixed a vaccum leak 2 weeks ago.

Thanks for the repost guys. By the way iT is loud as hell. I love scaring the shit out driver and the landscapers.....lol:muahaha:
 

·
Oh SNAP!!!
Joined
·
6,115 Posts
wow, i fixed a vaccum leak 2 weeks ago.

Thanks for the repost guys. By the way iT is loud as hell. I love scaring the shit out driver and the landscapers.....lol:muahaha:
get it right..i fixed it...lol...i hooked up my pressure tester...set it at 15 psi on the air compressor..and listen for any leaks he could of had...found a few..fixed em..and he had a bov sound...not to metion a more healthy running car...
 

·
Smash, Bang, AND Pow
Joined
·
833 Posts
i ran my normal open-loop for about a year and a half, then i took the fins out because i finally got tired of the loud whistle. i like how the Type II sounds, but i am going to throw another SSBOV (original pooped out) on there as the Type II doesn't like to open for low boost
 

·
Lifter Tick 4lyfe
Joined
·
430 Posts
are you shifting before it spools? like at low rpms?

i run an n/a so sorry if im wrong but i would assume youd have to run ur rpms high to spool high boost and because of the psi being high its released out and you hear "CCKKSHHHH" lol
my .02
Not really, my hks goes off under light loads, not even into boost.
 
21 - 40 of 40 Posts
Top