Mitsubishi 3000GT & Dodge Stealth Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
462 Posts
Discussion Starter · #3 ·
I replaced that fuse the other day, it is not blown now and yet the lighter does not work nor the rear wiper or the power mirrors, no blown fuses, no bad relays, I swapped the relays around and still no juice, any ideas?
 

·
Registered
Joined
·
462 Posts
Discussion Starter · #5 ·
I checked all fuses using a test light, I had power to both sides of each fuse. I am lost, I don't think any wires melted but thats what it seems like.
 

·
Registered
Joined
·
462 Posts
Discussion Starter · #6 ·
I checked all fuses using a test light, I had power to both sides of each fuse. I am lost, I don't think any wires melted but thats what it seems like.
 

·
Registered
Joined
·
462 Posts
Discussion Starter · #8 ·
I am sure it is not connections, something has definately happened to the power of the car, as far as electrical, no wiper in the rear, no power mirrors, the car seems stuck in economy mode, the button for that and for the overdrive are not working, so something is tied to all of these causing me a problem, going to do more wire testing today when i get home from work.
 

·
Registered
Joined
·
462 Posts
Discussion Starter · #10 ·
Try disconnecting the battery for about 10 minutes and then let the car idle for a little while.....maybe the ecu needs a reset......it sounds weird, but it's something to try.
I did that already after it was suggested, it didnt change anything. :(
 

·
Registered
Joined
·
462 Posts
Discussion Starter · #12 ·
The way so many things are being affected it seems like wires must be melted or something, I don't see what could affect everything like this. I don't see or smell anything though.
 

·
Registered
Joined
·
53 Posts
Same thing just happened to mine. Except my cig lighter still works. My rear wipper, and power mirrors don't work. Fuse is still fine though. Going to check all wires tonight and if I find something, maybe I can help.
 

·
Registered
Joined
·
2,531 Posts
Same thing happened to mine also. It is weird tho. B/c I have no power to my mirrors but when I turn the car off my left mirror turns all the way in. So everytime I drive it I have to set the mirror myself. Not fun when it is cold outside!

JM:mitsu:
 

·
Registered
Joined
·
462 Posts
Discussion Starter · #17 ·
No I didnt, I have basically taken the entire bottom off the dash, sterring column, console and found nothing wrong. any ideas?
 

·
Registered
Joined
·
2,531 Posts
241comp,
Yea, my mirrors started out turning the entire way in and still having power to move them back out! But, just wait the whole thing will just die and you will have no power. It took mine about 3 months to lose all of its power. Now mine does not move at all!

JM:mitsu:
 
1 - 20 of 21 Posts
Top