Mitsubishi 3000GT & Dodge Stealth Forum banner
1 - 4 of 4 Posts

·
Premium Member
Joined
·
9,023 Posts
Discussion Starter · #1 ·
Hello its me again the local post whore.

Lately the engine has been making strange noises right after starting up, and if you lean over the engine listening for it, it seems to be coming from the left side of the front valve cover underneath the ypipe. Somewhere close to where the BOV mounts. Sounds like gurgling water and wondering if the water pump needs to be looked at. Where is the water pump mounted on our cars? 91 TT.
Once it has run a bit the noise goes away. At first I didn't think it would be the water pump since just had one replaced recently at the dealership. Kind of makes a gurgle/hiss noise. I'm also getting occasional ticking too, but have 98 lifters installed already.

Not sure what is causing the tic noise, nor the water noise. Would like to resolve this soon, even if have to take it in to the shop. Don't want to burn out a water pump...to many things to overheat and break.

Lord Warlock
 

·
Registered
Joined
·
5,439 Posts
Water pump is on the opposite side, in the middle of the timing belt crap. The thermostat housing appears to be the spot where you hear the sounds at. No clue on what it is though - my car makes some weird noises too, but none I think (hope) are serious.
 

·
Premium Member
Joined
·
9,023 Posts
Discussion Starter · #4 ·
Well I'll rule out waterpump since no water noises are emanating from the right side of the motor. It isn't overheating so can't be much, just don't like hearing noises from under the hood. (cha ching)
 
1 - 4 of 4 Posts
Top