Mitsubishi 3000GT & Dodge Stealth Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
262 Posts
Discussion Starter · #1 ·
Yesterday, I got up for work went out and started my 92 stealth r/t. All seemed fine, backed it out of the garage and it quit. No indication that it was going to, just all at once. I finally get it restarted to move it back in the garage, but it is idleing real rough and doesn't want to run. The last time I got gas I filled the car up with 93 octane. I had went about 450 miles on that tank, so the car was almost empty when this problem started. I drained all of the other gas out of the tank, put in some dry gas, and filled the car with new gas, also 93 octane, from a different gas station. I drove the car about 10-15 miles last night and it seemed to be doing a lot better, had a slight hesitation but I figured that there may still be a little water in the tank or something.
Today I go out, the car starts up, and starts to sputter again. I drive it to work, and on the way it starts to run a little better, then I pull in the parking lot and the car dies.

Does this sound like I still have water in the gas? My check engine light or anything like that never came on. I pulled the front 3 plugs out and 2 of them had gas on them last night. I turned the car over with the plugs out, then dried the plugs off before reinstalling them. Any help would be greatly appreciated, and sorry for the long post, I was just trying to think of everything to put in there.

Travis
 

·
Registered
Joined
·
262 Posts
Discussion Starter · #5 ·
I put some dry gas in when I filled the car up. I guess I will try the fuel filter and see if that helps. Do you guys think it could be something else, other than the fuel causing this problem?
 

·
Registered
Joined
·
262 Posts
Discussion Starter · #8 ·
I bought a fuel filter, so I will put that on when I get home from work. When I went out I could barely get the car to start, it just wanted to turn over....I am beginning to think this isn't just water in the gas....

Does anyone have any other ideas of what this problem could be?
 

·
Registered
Joined
·
2,486 Posts
First thing you should do is replace that fuel filter it should be done every 60K anyway in my opinion, its cheap and its easy. Also make sure that all the injectors are in good working order put a meter to them or carefully pull them out for inspection, if you have time try replacing the spark plugs and wires I dont know how old they are and what condition they are in. finally try opening the screw on the fuel tank to drain a little more from it as you know the water will be in the bottom of the tank. Run so redline fuel injection cleaner in there. Hope this helps!
 

·
Registered
Joined
·
2,486 Posts
Just figured to mention one more thing the crank sensor may be going bad or it is bad, probably not the case but possible. Just check the basics I listed above and I hope it helps.

Oh and if you have time clean your throttle body I am sure you will see how dirty and shitty it looks inside once you open it up. Good luck!
 

·
Registered
Joined
·
262 Posts
Discussion Starter · #11 ·
Ok I will start with the fuel filter. After I drained all of the old gas out, put dry gas in and filled the car up it seemed to run much better. Then this morning the problems started all over again. I am not sure how old the plugs and wires are. I have had the car since September, and have put, maybe 6 or 7 thousand miles on it since then.

Could it be the crank angle sensor bad? I just keep thinking that since these problems just happened all at once, there has to be something else wrong...
 

·
STL3S
Joined
·
534 Posts
Check your connections on your battery also. Make sure they are nice and tight. (not handtight, use a wrench) I had a similar problem where my car began to stall and sputter really bad until finally it just wouldn't start. Low and behold, I put a wrench on the negative lead to tighten it down on the battery and the whole thing just broke in half. Needless to say, I got a new lead and I was good to go.
 

·
Registered
Joined
·
262 Posts
Discussion Starter · #13 ·
UPDATE:

I replaced the fuel filter and it was still running pretty rough. After a while it seemed to clear up some, and the car was running decent. I let the car idle for a while and the idleing seemed to clear up some. I shut the car off and started it again, then the problem seemed to get a lot worse. What would cause the problem to get worse after the car was shut off then restarted? I am running out of ideas....so if anyone could help that would be great.

Thanks
 

·
Premium Member
Joined
·
2,754 Posts
Sounds ignition related to me...intermittent problems often are. Change the plugs and wires, if that doesn't help, work your way up the ignition system until you find the problem. Plugs - Wires - Coil packs - PTU - ECU - Sensors. 1992 I would pull out the ECU and inspect it to make sure the capacitors aren't leaking.

Also, like said above, poor connection at the battery or alternator can cause all sorts of problems.
 

·
Registered
Joined
·
262 Posts
Discussion Starter · #15 ·
ANOTHER UPDATE:

I changed the plugs and wires and the problem is still there, not near as bad. It seems most prominant when the car is at 1 to 2 thousand RPM's. At a higher RPM the car doesn't sputter. The coils seem to be working pretty good. Could this be the ECU, PTU, or what sensor could it be that might cause this problem?
 

·
Registered
Joined
·
14 Posts
ANOTHER UPDATE:

I changed the plugs and wires and the problem is still there, not near as bad. It seems most prominant when the car is at 1 to 2 thousand RPM's. At a higher RPM the car doesn't sputter. The coils seem to be working pretty good. Could this be the ECU, PTU, or what sensor could it be that might cause this problem?
I know this is older but if you ran it low maybe that was the strain you put on the pump? It sounds intermittent. So, it works then doesn't means a part is failing or hadn't yet.. check YOUR Iac or just clean it. Reset your ECU, check your alternator and air. Just keep it simple. It still runs so all the above check. Low chance but timing? The name of the game is trouble shoot. Lin point and narrow it down to save money. Never shot gun. Good luck let me know how it goes. Brother
 
1 - 16 of 16 Posts
Top