Mitsubishi 3000GT & Dodge Stealth Forum banner
181 - 200 of 237 Posts

· I'm a Member
Joined
·
10,068 Posts
having said that, I'm not sure HOW a hub dyno can do this....hub dyno's have any way of linking the hub rotation between the boxes do they? I assume if this really was a serious issue there would be a whole lot less hub dyno's around, look at all the cars around with VCU's.

looking at the design of the VCU, under the circumstance the car experienced the VCU should have locked up quick smart, if it's only under high speed that it's starting to lock I'd even consider the possibility that it's started to leak and the plates just have no/very little liquid to harden against.

if you're near Carlisle towards the middle of the year I'm going to be in WA for a full month by the looks :)
 

· Twin Turbo
Joined
·
5,262 Posts
I never knew you took it to RPW...... why did you do that???????
 

· Premium Member
Joined
·
19,730 Posts
Discussion Starter · #187 ·
What happened was that we rocked up to use the dyno. Tristian wasn't sure that the right dyno boxes were at their right places. He thought that the ones at the front should be at the back. He then asked Dave and he said everything was fine where they were. tristian thought there could have been something wrong with the dyno setup (front wheels not turning) so we checked with Dave and he said dyno is fine, VCU is toast.

Scotty
 

· Registered
Joined
·
538 Posts
having said that, I'm not sure HOW a hub dyno can do this....hub dyno's have any way of linking the hub rotation between the boxes do they? I assume if this really was a serious issue there would be a whole lot less hub dyno's around, look at all the cars around with VCU's.
They do 'sync' between them... assuming its been setup correctly. Normally the torque settings for each box are the same and they can be adjusted to even the load/resistance between the axles.

Sounds like this dyno is a fucked up setup and is configured as 2 independant sets, each running 1 axle and not set to the same resistance. That won't have been good for the VCU..
 

· Premium Member
Joined
·
19,730 Posts
Discussion Starter · #190 ·
I can't give it a boot full as it lacks any real power, but it drives fine and there's no whine coming from the front or anywhere. Might take it out again this weekend and have a better look.

Scotty
 

· Registered
Joined
·
3,531 Posts
:bump:
 

· Registered
Joined
·
3,531 Posts
*tumbleweed passing by*
 

· Just lucky I guess.
Joined
·
1,660 Posts
Didn't want to derail another thread, so picking up from GT04,--- Yes, Scoot, how goes your beast ?
10 weeks roughly till I try and make it to yours. ( got a 60k kit from USA in mail, I'll double check T- belt is tight then I'm good. )
Two of us jogging round Perth on foot, just won't be good as driving around wearing big white wings.
 
181 - 200 of 237 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top