Mitsubishi 3000GT & Dodge Stealth Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 1993 DOHC ES , auto,86000 miles...in September I noticed my battery seemed low when starting my car. I cleaned the terminals and post...it got worse. The battery was 5 years old, so I bought a new one...It went dead. I put three alternators (parts store, rebulit) on it in 2 weeks. Finally I took it to my Dodge dealer...they told me "you've been getting bad alternators, let us put a mopar alternator on it" Well...12 days later I got my car back. It ran fine and everything seemed ok until about 2 weeks ago. I noticed it was sort of missing or surging at times. One of the guys that works at the dealer drove it and determined I needed plug wires. The night before I was gonna buy the wires...I noticed some of the warning lights (battery, brake and low washer fluid) were dimly lit while I was driving it. As I acclerated...the headlights begin to flicker. Don't sound like plug wires to me. Everytime you turn something on the warning lights will flicker. So...it's running rough and the lights are flickering. Anyone have a clue what might be wrong. Sorry about the long post...but I'm out $600 and getting frustrated. Thanks for any help
 

·
og
Joined
·
4,293 Posts
man, electrical probs are the WORST. obviously you've tried disconnecting the battery to clear signals... ummm... based on the missing/surging i might consider datalogging it since it's 1st gen, might also wanna get a reader and hook it up, check and see if you are getting any trouble codes (do a search for "trouble codes" might help). sorry i don't have any better advice for ya, something might be draining your electrical systems, perhaps your ecu has a prob, very curious issue. wish i had some better advice for ya, keep us posted, mebbe somebody else will have some ideas to share, ttt, good luck n safe travels.

- mike
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
still having probs

Thanks for the advice. When I had my Stealth at the dealer..during the alternator probs. I told them "the low fuel light stays on all the time...could there be a short somewhere causing my problems?" they said "Oh no..that woudn't cause any problems". I'm beginning to believe the posts about Dodge dealers not having a clue about how to work on Stealths. If anyone else has any ideas...I sure would appreciate it. It's aggrevating having a Stealth that performs like a 1982 Chevette. lol I want back the smooth acceleration I once had. Thanks for any help.
 
1 - 3 of 3 Posts
Top