Mitsubishi 3000GT & Dodge Stealth Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
1,056 Posts
Discussion Starter #1
roger and brian,
remember my problem? that my car feels very sluggish but I am maintaning boost at 15psi on 3rd, etc but droping down to 10psi on 2nd gear at 5500? well, ever since I had the car I've noticed a hissing noise emanating from the plenum or near the plenum...on the right side where the vaccum hoses are...I checked all the hoses and seem to be fine...I checked the i/c pipes and I/C...everything is normal...except for that hissing sound? could it be that the gasket between the valve cover and the engine is cracked...? what are the odds of that happening? do you have more insights as to what's going on? I also checked the gasket between the throtle body and the plenum and that's fine I even poured some soapy water to see if it leaked (of course, I acceletared)...well guys please let me know if you have any insights...I think my next step will be to check those valve covers..but then again I just did a compression test and all the 6 pistons are in the 152psi range. I am wondering if it is either one of the two gaskets between the lower intake block and the engine.
 

·
Registered
Joined
·
334 Posts
Not Roger or Brian, but I happen to be on while you posted, so I will respond with my view.


Since you hear a leaking type noise(hiss), I'm guessing when your plugs were changed or if at any time the plenum was removed the gasket between the plenum and intake was damaged or the bolts are not tight on top of plenum. Check the bolts. Just look around the whole plenum where exactly it's coming from. Hope this helps.

Mario

[This message has been edited by VR-4 Tissimo (edited December 12, 1999).]
 

·
Registered
Joined
·
1,056 Posts
Discussion Starter #3
mario,
thanks for replying again...well, yeah I just did the plugs...but that noise was there even before I did the plugs. I tried looking around that area...and I found nothing...I checked the gasket between the plenum and the engine and there are no cracks...and I tightened the plugs myself and re-check them...and they are tight...If I were to tighten more I think I'd break 'em...any more ideas? I can't really narrow down where the noise is coming from...but its around there...no visible vaccuum hoses are loose...I really don't know what to do, I've been driving the car like this for 2 years!!! I had initially thought it was the wastegate solenoid that was faulty but I got the hks evc ez...its a little better in performance but still my car cannot be compared to a running VR4...what's going on? please read my earlier post on the msgboard, mario...BTW, I just hooked up everything back to the stock solenoid and used a hand pump and T-connected it to the wastegate solenoid...and did the tests that the repair manual said on page 15-7 (look at the chart)...ok for the first test on the chart the air leaks (normal). for the second test, the air sort of maintained but slowly leaked out...and the third it was the same as the second test, it maintained but slowly leaks out...what's going on? so I do have a leak somewhere right? I use my blitz dual solenoid to monitor vaccuum and its around 44-52 mmHg...but one odd thing though, the stock boost gauge drops all the way down to the last line on the gauge when I turn the car on...my friend's gauge (lordDVD's) after turning the engine on the needle points to the second line prior to the last one on the gauge but I roger G. told me that it was because he has some kind of injector controller...but he doesn't...all he had was borla catback, k&N, blitz BOV, blitz dsbc...that's it...what about your car mario? please enlighten me if you have any insights will you? thanks!
 

·
Registered
Joined
·
1,010 Posts
Dave,

How's it going? I don't know where your leak is coming from but maybe I can help you find it. Get a can of carburetor cleaner or starting fluid (prefer carb cleaner) and start spraying around the area where you are hearing the hissing sound. Use the little plastic nozzle so you can isolate the spray to a small area. You should hear the idle change when you find the leak. Usually it will go up for a second and then come back down. Give this a try and you may be able to track down your leak. Be careful not to tighten the plenum bolts too tight. I think they are only torqued to about 14lbs and that isn't a lot.

If I can help you anymore, give me a call or email me.

Dan
 

·
Registered
Joined
·
1,056 Posts
Discussion Starter #5
dan,
thanks! you've been great help! what brand do you suggest I should buy? which one do you use? how come the idle will change? is it because this thing seals it up for a few seconds? take care dan! thanks again...and I'll try to give you a call tomorrow ok? happy holidays!

later,

dave
 

·
Registered
Joined
·
1,056 Posts
Discussion Starter #6
roger or brian,
since my car is sluggish...do you think the timing may be off? how can I check that? and How do I go about adjusting it? thanks and take care!
 

·
Registered
Joined
·
1,010 Posts
Dave,

Brand doesn't matter for this purpose I'd probably just get whatever is cheap. Yeah the reason the idle changes is two-fold. One you are briefly "plugging the leak" with the fluid that is being sprayed. Two you are injecting more "fuel" at the same time. The richer mixture temporarily offsets the "lean" codition made by the vacuum leak. Based on what logic tells me not by the book.

Dan
 

·
Registered
Joined
·
3,449 Posts
Try disconnecting the EGR valave under the T/B at the enge of the manifold. Possibly a stuck EGR causing a vaccum leak.. Actually pull it off and clean it out etc too while your at it. Also, check the brake booster and clutch booster lines to make sure your lines show the arrow going toward the engine, if one is backwards, this will cause a big leak when you go into boost. Timing, take off the plastic covers to the timing belt, then watch for the timing marks on the sprockets as vs the crankshaft pulley and make sure ALL line up PERFECTLY, if one seems to be a "little" off, then the timing is off, they should be PERFECT..
 

·
Registered
Joined
·
1,056 Posts
Discussion Starter #12
I think so...I am trying to find the leak but haven't gotten the time to buy a can of that carb cleaner yet cuz work is too much time consuming. come to think of it, I am not so ok...cuz, you see, our c5 friend (ray) wouldn't leave me alone...and he is always saying that your car is going to blow up. Yo, man! you gotta get back here and show this bastard what we 3siers are made of. I only have one more thing to say to you: [email protected]#ing COME BACK!!!!!!

p.s. I miss you man!!
 
L

·
Guest
Joined
·
0 Posts
Hey dude... u gotta stop this missing shit.. I think everyone thinks I'm gay. BUT GUYS I"M HAPPILY MARRIED!!
 

·
Registered
Joined
·
1,056 Posts
Discussion Starter #15
Veon,
Of course I miss you!!! I miss you more than [email protected]#ing hendrick! heheehehehe see you soon


Hendrick,
I understand you are married...but I still miss you, you know why? So get to ride your Turbo Beast!!!! 25psi with alcohol??? no knock??? what device are you using to monitor knock? and most important of all, how do fu#@k does it feel???? come on tell [email protected]!!!! and come back quick!!!
 
1 - 15 of 15 Posts
Top