Mitsubishi 3000GT & Dodge Stealth Forum banner
1 - 7 of 7 Posts

·
I like turtles
Joined
·
3,862 Posts
Discussion Starter · #1 ·
I get this wierd noise after I rev as the rpm's come down to idle. My engine sounds fine at idle no tick or anything. Then, when i rev its smooth until i let off. When the rpm's drop there is a rattle type gurgling sound coming from the engine area...what could it be? also...when i accelerate hard i can hear a chattering noise if i am by a wall that will bounce the noise back at me.
 

·
Registered
Joined
·
1,641 Posts
my car does that tick noise but i got it to where you cant even hear it. i just put in 5w30 motor oil..... with an K&N oil filter

i think its the lifters.... pretty much all the 3si's do it
 

·
Premium Member
Joined
·
880 Posts
I hate to bring up such an old thread but I have this same exact problem and I'm trying to figure out what it is. I've been searching the psat 2 days and cant find anything. Anyone know what this could be?? Thanks
 

·
Registered
Joined
·
911 Posts
what do you have along the lines of exhaust?testpipe,catback,ect.it might be exhaust noise.I have gutted precats,testpipe,downpipe,dnp catback.It seems to make a crackeling noise if I rev it hard.

greg
 

·
LessThanSane
Joined
·
752 Posts
I also have a ratteling noise, EXACTLY like Rebel. It is not lifter tick, which can be fixed with heavier oil (or new lifters). You can check that by listening closely to the front valve cover, If it's lifter tick it'll sound like they're beating their way out.
I have determined it has something to do with a belt. I'd like to say it's a tension pulley for the power steering or alt. But I really think it's the timing belt (SCARY!). I removed my top covers to check, and I see it wobbling, especially after I rev it. It seems like one side of the engine is moving faster than the other, creating slack. I would much rather say F*** THAT, since I put it on myself, and I know that if anything it's too tight...Which of course leads me to think, maybe it is too tight, so it somehow damaged the pulley on the water pump, causing the noise and the slack....
There's some of my random thoughts, Let me know if you think of something else.
 

·
Premium Member
Joined
·
880 Posts
I just got the wicked exhaust done yesterday (cut off at flange and run pipes back), still have cats, res. pre muffler etc. It has done it since I've had the car though. I'm gonna try and record it tonight.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top