Mitsubishi 3000GT & Dodge Stealth Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
172 Posts
Discussion Starter #1 (Edited)
This happened at roughly 2-3 psi while driving through an intersection in traffic. Not sure what caused it. Luckily all the pieces were found in the pre turbo pipes. Nothing after. New DR-650s installed + oil lines and running strong - good compression. Will post more on the build later. Have any of you seen this before?

Rear turbo (stock 9b):


Rear pre turbo intake pipe:


Front turbo (stock 9b):
 

Attachments

·
3SNY - HondaTurtleFTW
Joined
·
4,723 Posts
Looks like some thing got sucked into the intake and went to the rear turbo. Or a flaw in the machining of the compressor wheel.

Sent from my MB865 using AutoGuide.Com Free App
 

·
Registered
Joined
·
172 Posts
Discussion Starter #5
oh wow! are all bolts and nuts accounted for?
Coop
Yeap! No missing hardware. I thoroughly cleaned my intake and intercooler piping prior to installing the DRs.
 

·
Registered
Joined
·
172 Posts
Discussion Starter #6
Did you get these from Dynamic racing?
Oops, forgot to mention these are just the stock 9bs. Edited my post to include this info sorry. :eek:
 

·
Super Moderator
Joined
·
9,111 Posts
I thought it looked like a 9b lol... but you said DR650 installed, so I got confused.

How many miles on them? And was this out of nowhere, or had you done some work on the car prior?
 

·
Escaped
Joined
·
4,773 Posts
If you need a set of 9b's I am selling a set.
 

·
Registered
Joined
·
172 Posts
Discussion Starter #10
I thought it looked like a 9b lol... but you said DR650 installed, so I got confused.

How many miles on them? And was this out of nowhere, or had you done some work on the car prior?
They were 10k miles over due for a rebuild so I wouldn't say it was out of no where. Surprised it happened at such low boost though. Currently it's my daily driver so I baby it way too much. I only open it up on free way ramps after the clutch is fully engaged and even then my max EBC setting is 12psi. I only use the freeway a few times a month.

If you need a set of 9b's I am selling a set.
I installed DR650's last weekend. :)
 

·
Registered
Joined
·
172 Posts
Discussion Starter #12
10k past a rebuild? Curious where you got that info as I have seen many stock turbos go for 150k+, surly you dont have that many miles.
Coop
Shaft play at 120k inspection.
 

·
General & A/V Moderator
Joined
·
7,249 Posts
Well that explains things lol! How are you liking your billets? Notice a difference?
 

·
Registered
Joined
·
172 Posts
Discussion Starter #14
Well that explains things lol! How are you liking your billets? Notice a difference?
Unfortunately I Haven't been able to take it out yet - I wasn't careful enough with the radiator install and the A/C bolt mangled it. The engine runs well but I can't put it under load until I get the new one, which I just picked up today from Performance Radiator for $150 (oem spec). I'll let you know though! I took quite a few pics I'll share soon. :)


A/C bolt (Image courtesy of 3SX):
 

·
Registered
Joined
·
172 Posts
Discussion Starter #16
Is your MAS webbing still there?
Yeap and in perfect shape. That was one of my first thoughts but no missing or damaged honeycomb whatsoever!
 

·
Twin Turbo
Joined
·
5,115 Posts
Did you replace your intercoolers? Could be debris in them. I wouldn't have though the wheel would shatter like that just with shaft play.

Sent from my GT-I9000 using AutoGuide App
 

·
Registered
Joined
·
172 Posts
Discussion Starter #18
Did you replace your intercoolers? Could be debris in them. I wouldn't have though the wheel would shatter like that just with shaft play.

Sent from my GT-I9000 using AutoGuide App
I cleaned them. No particles were found within the intercoolers / intercooler piping though. That made me feel a bit better.
 
1 - 19 of 19 Posts
Top