Mitsubishi 3000GT & Dodge Stealth Forum banner

1 - 3 of 3 Posts
C

·
Guest
Joined
·
0 Posts
Discussion Starter #1
After finding a half way decent straight away I launched at 4,000 rpm(wanted to do at least 5,000) and took off. I only planned on doing a 0-60, but couldn't resist the rush and did a 1/4 mile run. My 0-60 time was 4.7 and quarter time was a 13.6 at 102.9 mph. Putting into play the crappy launch and the + or - of the getch, does this sound like a good time for having a GReddy exhaust, ProfecB controller, weapon/R filter, and under drive pulley? I also forgot to double check to see if my controller was letting my turbo's put out 15 psi. Also, is the max stock boost of 15 caused by the fuel pump, and or the inectors? Reason why is I also have a Kenne-Bell boost a pump that should deliver more fuel. But I understand that if the injectors are maxed out it won't matter.
 
L

·
Guest
Joined
·
0 Posts
Discussion Starter #2
I did 13.18 on my Gtech when I was having my stock turbos. All I had was a Blitz DSBC, borla exhuast w/ atr downpipe and ngk plugs, K&N and a 6,000 rpm launch with my turbos maxed out with 126 leaded gas mixed with 94 unleaded octance gas. Which should be around 110 octane.
 

·
Welcome To The Machine
Joined
·
951 Posts
I found the GTech to be extremely unreliable with our cars. I made several runs at the dragstrip with it some months back and it averaged .7 fast. On one run it said I did 12.43 @ 119mph (boing!), but when I got my timeslip I only did 13.3 @ 105mph. I sent the thing back. It seemed to be pretty consistent with HP measures however. On the 1/4 mile runs the times were all over the map compared to the dragstrip times. Sometimes it would be pretty close, but the GTech never clocked faster than the strip timed runs. If your run was accurate, I'd say that it is pretty decent. I'm not very consistent and my times would sometimes vary as much as 3/4 sec.

Bruce
3Si #0243

[This message has been edited by Bruce (edited December 15, 1999).]
 
1 - 3 of 3 Posts
Top