Mitsubishi 3000GT & Dodge Stealth Forum banner

1 - 5 of 5 Posts
K

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Today on the way to work I was turning off on to a side road. I was braking going through the turn and when I came out of it I put it down into second gear causing the front tires to spin alittle(the roads were still alittle slick from last nights rain). As I was getting back up to speed when my Anti-Lock light came on but nothing seemed different. It had come on once before but reset itself after I turned the car off and turned it back on. This time when I turned my car off the light came back on. But ince again nothing seemed wrong, on lunch break I took it out for alittle and messed around to see if I could find any symptoms. At first it seemed like there was some resistance in the right front brake(the turn I went around was a right hand turn). I then went into an open parking lot(it is now raining and everything is wet) and threw it in reverse and took it up to about 30mph and slammed the brakes to the floor, they worked fine nothing locked up. I then put it in first took it up to 30 mph, slammed on the brakes and nothing, just a very impressive stop for the rain. On the way home from work I was messing around trying everything I could(fast acclerations, hard stops, sharp turns, tire spinning) just to see if I could get the light to go out.....nothing. When I got back to my house I took it up to about 55mph and slammed on the brakes, tires didn't slide just another quick stop. When I got out of my car I noticed a buzzing sound coming from my right front wheel well and a slight vibration through the brake pedal even when the car is turned off. I asked the local mechanic and he said when my tires spun going around turning off on to that side road it may have vibrated enough to knock one of the Anti-Lock sensors out of place. Is that possible? OH yeah one more thing. There use to be a nice vibration when I hit the brakes(warped rotors is my guess) now that this has happened there is hardly any vibration when I step on my brakes, even if I slam them to the floor. Might I be in need of new pads or rotors? Could this be something else? I know someone on this board could probably tell me whats wrong. I just need to find a cure. I can already feel my heartbeat slowing down. I love this car and want to take good care of it. Someone PLEASE help!!!!!
 
B

·
Guest
Joined
·
0 Posts
Discussion Starter #2
When you say you hear a buzzing sound, is it coming from the wheel well, or does it sound like it's coming from over the wheel well. The buzzing sound sounds to me like it could be something as simple as the ABS power relay being stuck, but on the other hand, the hydraulic unit ($$$$) is also located in that area. Pop open the hood and see if you can feel where the vibration is coming from. If it turns out to be inside a little box holding a bunch of relays, it will be the ABS relay. If on the other hand, it sounds like it's coming from in front of the wheel well in what appears to be a hidden area, it's the ABS hydraulic unit. To the best of my knowledge, the only way to absolutely test this is with one of the Miller Scan tools (more $$$), but hopefully I'm wrong. When the ABS system fails, the failsafe mode is for the brakes to act like they are normal, non-ABS brakes. If the hydraulic unit is diagnosed to be bad, make sure they at least flush the unit to ensure there isn't a clog in it.

I seriously doubt that it's the ABS sensor.

Good Luck,

Bill Wagner
 
K

·
Guest
Joined
·
0 Posts
Discussion Starter #3
I went out to my car today and the battery was dead. Dammit, works not going to like that. Hey maybe at the very least the problem reset itself. What to do, what to do??
 

·
Registered
Joined
·
63 Posts
That same thing happened to my car, twice!
What I did was disconnect the battery for a few seconds and reconnect it.
The buzzing sound disappeared.
Still don't know why that happens.
 
K

·
Guest
Joined
·
0 Posts
Discussion Starter #5
Well thank you Bill, XRD-1, and Kevin. When I got my car jumped this morning the light didn't come back on with the car(so far). This atleast saves me $50 that I woulda spent at a Dealer getting it put on a computer and gives me more money for this Sunday at D&B's. heheh....
 
1 - 5 of 5 Posts
Top