Mitsubishi 3000GT & Dodge Stealth Forum banner

1 - 6 of 6 Posts

·
Open it up!
Joined
·
334 Posts
Discussion Starter #1
I have the annoying problem of the coolant light coming on frequently. I fill it up, then it comes back on. Had the car to the dealer 800 miles ago and they warmed it up, did a pressure test, and could find nothing.

There's no sign of leaking coolant on my garage floor.

The dealer says there's no sign of coolant in the engine - he said it would be very visible by turning white. is this true? even with mobile1?

So 800 miles later, the coolant light is back on again and I drive it that way to dealer. He pressure tests it again for 20 minutes and can't find a leak again. WTF??

I have about 1 month left on my factory warranty and need to get this fixed. Anyone have any ideas?

Jeff
 

·
Premium Member
Joined
·
3,338 Posts
Possibly the water pump weaping under your timimg belt covers. Hard to get to to look at, but may be the problem.
Steve
 

·
Registered
Joined
·
145 Posts
Hate to tell you, but its sounds like your water pump....
when the car is not running, it doesnt leak.... could be why the compression test passed....
I had the exact same problem, no sign of leaking etc, I kept filling it up and up and finally it got to the point where if you run the car have a quick spin around the block, then stop and look under your car, might see it leaking... but definetely sounds like the water pump, I had no sign of leakage for a while...
All I kept seeing is that damn roman cathedral type icon light thing hehe
 

·
chunsangp
Joined
·
3,556 Posts
That's exact same thing happened to me like 2 months ago.
I couldn't find any leak under the car so I took it to the dealer
and let them have pressure test. They couldn't find any problems.
OK, later, I found out i had bad radiator cap.
Try to retighten your rad cap or replace the cap and the gasket. Your issue could be very minor just like me.
Good luck!
 
1 - 6 of 6 Posts
Top