Mitsubishi 3000GT & Dodge Stealth Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
Alright, Just before school started I got a '92 3000gt with a busted Timing belt. Weel I've been working on it off and on since and now i finally got everything fixed up. (new valves, belts, plugs and such.) Anyways, I go to start it up for the first time and nothing happens, just a slight clicking sound that is not the starter. The battery is fine. Ok so i get back out of the car and notice after opening the door all the turn signals are blinking so i get back in and so are all the dash lights and everything. So for the longest time i can't figure out whats going on. I think one possibility is that its an alarm but i tried the key in the dor and everywhere else and it wont shut off the blinking and stuff. also the horn isn't going off, that doesn't fit an alarm system does it. Also tried unhooking the battery and putting it back on. checked the clutch switch and starter connections.

has anyone experienced this. do the dash lights flash when the stock alarm goes off? Is there any other way to shut off the alarm that i haven't tried? The guy said he was the first owner but the key he gave me wasn't the original and also no remote.

I just wanna start the damn thing up to see if all my work paid off

Thanks
 

·
SE Texas Member
Joined
·
79 Posts
I don't know if this will help, but look for a switch under the steering wheel or on the panel by your left leg. You might have an aftermarket alarm like I have on my car.
The battery died in my remote so for now I use the key to unlock the doors but the alarm went off every time and made too much noise, so I disconnected the horn so that only the lights flash and the car will not start. To start the car and to get the lights to stop, I have to turn on the ignition switch and move the hidden alarm switch up to disable the alarm and set it to valet mode.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #6 ·
thank you guys for your suggestions. I finally found the guy I bought it from and asked him about alarms. He said he wasn't aware that there was an alarm on the thing. So... I have been rechecking all the stuff i rebuilt for the timing belt fix. If I had not put the cam rotation sensor in the correct way (flipped) would this kind of warning occur?

Also there is one plug that I'm pretty sure had nothing attached to it to begin with but possibly. andways, would this also result in flashing lights and dash?

thanks for trying to help me out.
 

·
Registered
Joined
·
10,686 Posts
Advise if you can honk the horn and if the headlights work correctly.

Also, you can try setting the factory alarm to see how it behaves. (horn and lights should flash when you open a door with the alarm set. Key in ignition should disable it.)

The symptoms you describe sound like an aftermarket alarm with a broken or missing siren. My Viper system will go on when you reconnect the battery and requires the remote to turn it off.

If you ar lucky, you may have either a disable switch for the alarm. Disconnecting it will require you to find where they hacked (and in my personal experience, I do mean HACKED) into your wiring harness, generally near the fuse box, and undo the damage.




Clint
 
1 - 7 of 7 Posts
Top