Mitsubishi 3000GT & Dodge Stealth Forum banner

1 - 20 of 47 Posts

·
Registered
1991 Stealth Es
Joined
·
171 Posts
Discussion Starter · #1 ·
So this is how my lifters sounds 6 months later i think this still sounds like lifter tic? Oil 5w 50.


Thanks!
 

·
Registered
1994 Mitsubishi 3000gt VR-4
Joined
·
210 Posts
Probably should be using 5w-40(What I use) Or 10w-40 what some others on this forum use.
 

·
Registered
Joined
·
10 Posts
Take a peek inside your front head, maybe you get lucky and find one collapsed. The gasket is only a couple bucks. I did one on the battery side without having to remove any timing components.

I never like to use different oil in the car, but she is old and gets hot on long drives. These amazing guys on this forum recommend the 5w40, and i haven't had a low oil pressure since.
 

·
Registered
91 VR4 wish scissors BBK wheels and tint
Joined
·
209 Posts
use better oil for the car...

too thin (lower number) and it cant take pressure on smaller journals or hold pressure in the big ones
too thick (hugher number) and its hard to pump to the smaller parts, and when it gets to those areas it may have too little flow rate.

I run 10-30 in the VR4
 

·
Registered
1991 Stealth Es
Joined
·
171 Posts
Discussion Starter · #6 ·
I have had the valve cover off and like everything was in its place i used 5w 50 cause with 5w 30 i got the oil light on oil pressure now with 5w 50 20psi hot idle and the lifters were high quality ones from evile empire performance so i think that they cant have collapsed allready. Im just wondering do you guys think that it sounds normal?
 

·
Registered
1991 Stealth Es
Joined
·
171 Posts
Discussion Starter · #7 ·
When i installed the lifters i didnt prime them but they went quiet after like 30min so can that be a probelm
 

·
Registered
91 VR4 wish scissors BBK wheels and tint
Joined
·
209 Posts
I have had the valve cover off and like everything was in its place i used 5w 50 cause with 5w 30 i got the oil light on oil pressure now with 5w 50 20psi hot idle and the lifters were high quality ones from evile empire performance so i think that they cant have collapsed allready. Im just wondering do you guys think that it sounds normal?

Dont trust the Dash gauge... they often read low
Change your oil and use the manual recommended 5-30 or maybe a 10-30 as that is still within spec.)
Too thick and they do not flow well. THIS IS A PROBLEM.
Obviously they dont sound right, if it did we wouldn't be in this thread.

When i installed the lifters i didnt prime them but they went quiet after like 30min so can that be a probelm
The only reason to soak them is to prevent the wear that happens before they fill with oil.
you may have screwed them up by not.
 

·
Registered
1991 Stealth Es
Joined
·
171 Posts
Discussion Starter · #11 ·
Dont trust the Dash gauge... they often read low
Change your oil and use the manual recommended 5-30 or maybe a 10-30 as that is still within spec.)
Too thick and they do not flow well. THIS IS A PROBLEM.
Obviously they dont sound right, if it did we wouldn't be in this thread.


The only reason to soak them is to prevent the wear that happens before they fill with oil.
you may have screwed them up by not.
Could it really have broke them cause i did heard people have done it like i did too?
 

·
Registered
1991 Stealth Es
Joined
·
171 Posts
Discussion Starter · #12 ·
Yes, your valvetrain is making bad noises.

change your oil to 10-30
I will try that when i get my coil on plug kit from rvenge performance cause i have the gas in my oil cause i think my cars running on 5 cylinders some time
 

·
Registered
91 VR4 wish scissors BBK wheels and tint
Joined
·
209 Posts
Could it really have broke them cause i did heard people have done it like i did too?
There is a reason all of the people who MAKE the parts say this is how to install and break in...
Dont listen to the vast majority of the people online... they do not know better.

Read the instructions and follow what they say.
 

·
Registered
91 VR4 wish scissors BBK wheels and tint
Joined
·
209 Posts
I will try that when i get my coil on plug kit from rvenge performance cause i have the gas in my oil cause i think my cars running on 5 cylinders some time
ah yes, I recall that thread...
you never posted photos of your plugs.

Also, when gas is in your oil the oil is thinner and no longer lubricates.

do not drive the car until you change the oil.

if you keep driving it as it sits you will ruin the engine and need a full rebuild (expect that to be 3000-5000 euro for full bore/pistons/head rebuild etc etc)
 

·
Registered
1991 Stealth Es
Joined
·
171 Posts
Discussion Starter · #15 ·
ah yes, I recall that thread...
you never posted photos of your plugs.

Also, when gas is in your oil the oil is thinner and no longer lubricates.

do not drive the car until you change the oil.

if you keep driving it as it sits you will ruin the engine and need a full rebuild (expect that to be 3000-5000 euro for full bore/pistons/head rebuild etc etc)
Yes i will do that and see if the tick goes away
 

·
Registered
1991 Stealth Es
Joined
·
171 Posts
Discussion Starter · #16 ·
And if not i dont know what to do. im only 16 i dont have money for this lol
 

·
Registered
1991 Stealth Es
Joined
·
171 Posts
Discussion Starter · #17 ·
ah yes, I recall that thread...
you never posted photos of your plugs.

Also, when gas is in your oil the oil is thinner and no longer lubricates.

do not drive the car until you change the oil.

if you keep driving it as it sits you will ruin the engine and need a full rebuild (expect that to be 3000-5000 euro for full bore/pistons/head rebuild etc etc)
Well i have read and people say that it is fine not to prime lifters but i cranked the car like 15 seconds before i started it. But do you think like 5w 40 will be good cause i dont wanna go to a very thin oil like 10w 30.
 

·
Registered
1991 Dodge Stealth ES 5sp
Joined
·
188 Posts
If you have an oil LIGHT come on from running 5W-30 you might have another issue.

I run 5W-30 Castrol synthetic in my 91 ES, original lifters, and it is fine. Oil pressure is good. Lifter tick only if it's sat for a while, but goes away after it warms up. If I drive it everyday, there isn't really any lifter tick on start up. When I first bought the car, the oil was dirty and lifter tick was a lot worse - after a few oil changes, it's gotten to where it is now.

I drive the car casually/spirited Spring-Fall. Ambient temperatures range from 15°C - 40°C. No issues.

If I was tracking it/running it really hard, then sure I might change the oil weight, but for "daily" activities, the OEM recommended oil weight is ok.

I know some people who have had some luck running Rislone Engine Treatment with a fresh oil change to clean out any crap in the system. Then just another fresh oil change after running it a while.
 

·
Registered
91 VR4 wish scissors BBK wheels and tint
Joined
·
209 Posts
Well i have read and people say that it is fine not to prime lifters but i cranked the car like 15 seconds before i started it. But do you think like 5w 40 will be good cause i dont wanna go to a very thin oil like 10w 30.
What people say and what is proper are not the same.
The mfg says prime or soak, you should prime or soak.

You say 15 seconds but above you said it made noise for 30 seconds.... Those lifters are probably pretty beat up.

Why are you obsessed with running thick oil?

Mitsubishi knows the engine and how it's made... They wrote the manual and it says 5-30w.

Finland is not know for extreme temperature, run the proper weight.

Sent from my LM-G850 using Tapatalk
 

·
Registered
Joined
·
955 Posts
People are throwing out terms like "prime" when it comes to the lifters, so I just wanna clear something up. The factory service manual states that new lash adjusters(lifters) should be installed "air removed". The stealth manual is a bit more specific, saying to put the lifter in diesel, and purge the air by pumping on it a few times. If you are installing the lifters fully primed, as in putting them in oil, depressing the ball bearing and pumping the lifter until it is full and can't be compressed by hand, you are doing it wrong.
 
1 - 20 of 47 Posts
Top