Mitsubishi 3000GT & Dodge Stealth Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
575 Posts
Discussion Starter · #1 ·
Lately my car has developed a missfire and the idle has gone haywhire. It's idleing at around 1100 and it will jump up to 2500 and them back down again. I changed the plugs and checked the wires and it's still doing it. Any ideas? Coilpack? A sensor? Please any input or advice is much appreciated!:)
 

·
former 3s owner :**
Joined
·
2,561 Posts
also could double check your IAC and clean it.. 2500 is kind of high for it to jump though.

maybe ECU, pull it to check the capacitors (especially if its a 1st gen)
 

·
Registered
Joined
·
575 Posts
Discussion Starter · #3 ·
I'm pretty sure that I don't have IAC it's a 93 ES NA. I do have the variable intake on my plenum if that's what you mean, although I haven't disconnected or messed with it at all. Now when you say 1st gen, do you mean 91's or 91-93? Was the 93 ES one of the models known to have problematic ECU's?
 

·
Registered
Joined
·
10,686 Posts
All models use an IAC driven by the ECU to control the idle speed.

Suggested order to isolate the problem.

1. Make sure that all throttle control linkage moves freely and is free of corrosion. (I use a silicon lubricant on mine but opinions vary on what if anything to use on the linkage.)

2. Try resetting the ECU by disconnecting the battery for 30 seconds and see if the idle settles out. (Perhaps your ECU is off in la-la land.) You know your ECU was reset if your climate control is showing 77 degrees when you start your car.

3. The fact that you said you have mis-fires as well as irratic idle would make me suspicious of the ECU. Worth pulling it out and seeing if there is any leakge from the capacitors. (This has been found to be a problem with the first generation of our cars. Not sure if the capacitors got any better in the second generations or if the problem presents itself after 7-8 years.)

4. Next on the list would be to clean your throttle body and IAC


(Gotta get this info a FAQ called "Idle Problems"!!)



Clint
 

·
Registered
Joined
·
10,686 Posts
Black_Sunshine

How poorly would you expect the engine to run/idle if the timing belt were off even one cog?


Clint
 

·
Premium Member
Joined
·
6,598 Posts
7 Deg off.

Could be ECU..........
 
1 - 8 of 8 Posts
Top