Mitsubishi 3000GT & Dodge Stealth Forum banner

1 - 6 of 6 Posts

·
Flying Taco
Joined
·
56 Posts
Discussion Starter #1
I just bought my first 3000GT VR4, it is a 95 with 49k miles. There are a couple little problems, some which I found answers to on the FAQs and others I just am lost on.

(Problem 1) When I brake or move very slowly (parking speeds and every stoplight) there is a loud squeaking noise coming from the front of the car, almost like a belt slipping or something, but the noise goes away as soon as a decent speed is reached. Its not from the brakes because it makes the noise no matter whether the pedal is pressed or not. Im lost here.

(Problem 2) There is a strong clutch type smell occasionally when driving at low-rpms or reverse. Im sure this is the original clutch and it seems to engage and function correctly, but sometimes it just smells horrible as if I was beating the hell out of it.

Thats all that I can come up with now, thanks for all the help!
 

·
Flying Taco
Joined
·
56 Posts
Discussion Starter #2
TTT

Help! :)
 

·
Booooossstt
Joined
·
6,788 Posts
im no 3s expert but i do try to get experience diagnosting cars : ) let me take a stab at yours.

Problem 1 - it may be a brake rotor that is warped, it could be a wheel bearing, it could be your belts, check those they are very easy... try to pinpoint where the squeekin is comin from... if need be do your lil stoppin in yoru driveway with a friend there and the hood open you have to pinpoint it to get an idea...

problem 2 - im not sure about the types of clutches in these vehicles but they may have the kind that use weights to get extra centrifugal force and at faster speeds the clutch then grips better so at lower speeds it woudl be slippin in a way and causin the nasty odor of something bein burnt. time to get your tranny off and have a look yourself dont forget that if you do get a new clutch you get the flywheel resurfaced.

goodluck
Sean
 

·
Registered
Joined
·
12 Posts
I have the exact same problem on my 93 vr4.. I am 70% sure its the belts. I am actually going to get them replaced and i'll let you know if my problem was fixed or not.
 

·
Flasher
Joined
·
9,660 Posts
Holy shit I almost replied to this. Come on dude. An 11 year old necro-bump? Seriously? I don't think the "new owner questions" section was even around back then.
 

·
Woot!!!11one
Joined
·
256 Posts
Ok, thats awesome.
 
1 - 6 of 6 Posts
Top