Mitsubishi 3000GT & Dodge Stealth Forum banner
1 - 4 of 4 Posts

·
Like a Rat out of Water
Joined
·
2,976 Posts
Discussion Starter · #1 ·
I'm thinking I have a bad MFI relay switch. I get absolutely no power to the fuel pump, or fuel pump relay switch. I'd like to go to a junkyard and possibly pick one up, but the chances of finding a 1991 VR-4 are slim to none. Does anyone know if the base and SL models had the same MFI relay? Did all years have the same relay ?

-Bat
 

·
More Than Meets the Eye
Joined
·
4,632 Posts
I can probably get you that relay. We've got a couple of parts cars here (92 and 93).

Have you checked your ECU? It's a lot more likely that its failed than that relay.
 

·
Like a Rat out of Water
Joined
·
2,976 Posts
Discussion Starter · #3 ·
No, it's the MCI. Here's why.....the previous owner of my car installed a car phone. She took it to a "professional" car phone installer. Well, they were probably unfamiliar with our cars and the location of very important things such as our MFI relay. So they drilled a hole to mount the cell phone and the drill drilled a hole right through the casing of the MFI, but did not damage the relay at all...got real lucky...So, the cell phone mount was rattling around like crazy because the screw are mounted to nothing more than the carpeted side panel...so I do the logical thing and tighten the screw...three of them don't grab on anything...one does...however, I had no idea it was grabbing on the hole already drilled in the MFI casing...so the screw goes in the hole and actually closes one of the relay switches! Well, my car runs like a champ for a while until I bring it down to idle and it dies. I troubleshooted for hours and finally found out that the MFI was bad...when I shake it, I hear stuff rattling inside...not good!! I take it apart since it's already bad..a wire falls out and one of the relay switches has black spots on it...it's got to be bad...

Well, that's my story and I how I spent all of my relaxing Sunday....

If you can get me a switch, that'd be awesome...it's the only thing keeping my car from running right now...e-mail me at [email protected]

-Bat
 

·
Like a Rat out of Water
Joined
·
2,976 Posts
Discussion Starter · #4 ·
By the way, the MFI relay is a bronze box with a single connector and has 9 pins on it. I'm going to post picutres of mine tomorrow...was wondering if anyone knows if they are the same on all years and models?

-Bat
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top