Mitsubishi 3000GT & Dodge Stealth Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
my car seems to be lacking power in the 5000+rpm range, it seems to pull real good until i hit 5000. any suggestions. I have stock boost settings for now and i havent put the stillen downpipe on yet. possible clogged cats??new wires and plugs didnt help.car has 85K on it.
 

·
Me Tarzan..u Jane
Joined
·
4,002 Posts
Search for "hesitation" and you will come across of a lot of solutions but mainly is cause by the plugs. what gap were the plugs set to, and didt he Coils look like they had any corrosion down inside????
 

·
chunsangp
Joined
·
3,556 Posts
Isn't that normal/? After 5000rpm or so, those 9bs can't hold enough boost to the redline.......:mad:
 

·
Premium Member
Joined
·
1,784 Posts
Its likely your turbos. If they're stock. They're not defective or anything, the stockers just can't flow that well in the higher rpm range.

When all I have on my car was a EBC and Intake, my car would pull really hard between 2500-4800 rpm. Above that, you could noticeably feel a lack of power afterwards.

It did get a little better though when I put in a testpipe (no cat) and an aftermarket downpipe (Bob Melton). Now it pulls better through the higher RPM range, although I know it's still not holding .95 bar to redline.
 

·
Registered
Joined
·
9,645 Posts
if you feel it lagging (building up power then starting to shudder or hesitate, just not smooth acceleration) then its most likely the plugs. If it accelerates very smoothly through all rpms and just accelerates not as fast as the rpm's increase, thats the turbos. theyre too small.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #6 ·
yeah, i think its the turbos. it runs smooth through the rpm range. i just installed a boost gauge and it shows 14psi until about 4800rpm then falls off to 10psi. will this get better when i put the stillen down pipe on. it deletes the front precat and main cat and i am going to gut the rear pre cat. A question off the subject what should my car run in the 1/4 mile with the boost set at 14.5psi and the mods i listed...??
 

·
Me Tarzan..u Jane
Joined
·
4,002 Posts
chriswtx said:
yeah, i think its the turbos. it runs smooth through the rpm range. i just installed a boost gauge and it shows 14psi until about 4800rpm then falls off to 10psi. will this get better when i put the stillen down pipe on. it deletes the front precat and main cat and i am going to gut the rear pre cat. A question off the subject what should my car run in the 1/4 mile with the boost set at 14.5psi and the mods i listed...??
if thats the case, the only thing that will fix your boost problem is bigger turbos...Stock they should run 13.5 but that depends on how you drive. My first time with just intake and boost controler and slipping clutch got me a 14.2
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #8 ·
:D all fixed..i installed my mbc and set it up for 14psi. it now holds 14psi all the way to redline no problem!!runs like a scalded dog, i cant wait to put in my stillen down pipe. P.S. made my own ball and spring MBC with parts from Home Depot for $14. Works great so far!!:D :dodge:
 

·
Me Tarzan..u Jane
Joined
·
4,002 Posts
how did you do the impossible. our stock turbos start to loose boost over 4500rpms no matter how much they make before hand....I have a MBC set to 15psi and still only get ~10psi at 7K...
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #10 ·
i dont no. i did a 2nd gear and 3rd gear run and it held 14psi up to 6500rpm where i shifted.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top