Mitsubishi 3000GT & Dodge Stealth Forum banner
1 - 4 of 4 Posts

·
Hitokiri Battousai
Joined
·
8,545 Posts
Discussion Starter · #1 ·
Can anyone give me a good opinion on what I should check/do?

I've had my car for about 6 months now. I bought it off a dealer lot with 87,000 on it, and running beautifully. It now has 103,000 (I have a long drive to work - staying with friends now to cut the miles off) miles on it now, and I've run into a problem.

About 3 days ago, my coolant light came on. I found that I had lost about 8-10 ounces of coolant. Replaced it, and the light is back on the next day. I refilled it again today before driving home. I can't see any leaks and I don't smell it coming out the tailpipe. My upper rad. hose is pretty soft, so I'm going to replace it as soon as possible.

Also today, I was doing a quick jog home (ie- raced a 323ci and a talon TSi) and noticed a sound that reminded me of a rod knock at the upper rpms - 5,000 plus - but only in 3rd and 4th gear. I'm not going to push the car too much to hear this sound until I can confirm where it is. I'm hoping for something with the clutch myself, but the coolant loss that mysteriously appeared has my concerns on the engine itself.

Any ideas?
 

·
Registered
Joined
·
580 Posts
if there is white smoke coming from the exhaust, then its an internal engine problem(head gasket ??). Otherwise could be a water pump leaking. Mine started leaking at about 130K miles.
 

·
Registered
Joined
·
580 Posts
it's normal to have a small amount of "steam" until the engine is throughly warmed up. But "smoke" is different, smoke is denser/thicker then steam and is generally there whether the engine is warmed up or not.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top