Mitsubishi 3000GT & Dodge Stealth Forum banner

1 - 6 of 6 Posts

·
BFA
Joined
·
1,180 Posts
Discussion Starter #1
First, my antenna motor used to keep going after then antenna was already down for about 5 seconds. I didn';t really care. BUt then about 3 days ago, it got really cold here, and my antenna didn't go all the way up, and the motor kept trying to put it up. So I thought I would help it, and when I got it all the way up, the motor stopped finally. Then when I turned my car off, the antenna only went half way down, so I again helped it down to get the motor to stop going. Soon it wouldn't go up or down and I had to force it in each direction to get the motor to stop going. But tonight when I just got home, I pushed the antenna all the way down, and the motor didn't stop. I unscrewed the metal cap around the antenna to try to play with it, but it didn't stop. I looked for a fuse to pull to get it to stop, but I didn't see any labled antenna. I ended up just disconnecting the battery to save it. Is there a fuse I can pull anywhere? I really don't want to spend any money right now trying to get it fixed, and I really don't need the radio because I like my cds better. I think the problem is only the motor, and I think the white plastic cord I heard about is still intact. I just can't get the stupid motor to stop running. Any answers? THanks.


Jason
92 Stealth R/T TT
 

·
Premium Member
Joined
·
4,769 Posts
I've never done anything wiht my stock antenna and never had any problems with it. but then again I never use it either...

BUT, you might try just unplugging the wiring harness from the antenna motor itself, at least until you can get it fixed. Sounds like you need to replace the plastic shaft that pushes it up and down. I think you can just remove the little flap/panel back on the side in the trunk (may have to pull out the plastic tray first, 3 or 4 screws) and reach in and just unplug the harness/clip from the antenna motor.

EricB
 
C

·
Guest
Joined
·
0 Posts
Your antenna motor is fine, the reason why it keeps running is because the piece with the teeth is broke. When the antenna goes up half way and the motor keeps running it's because it no longer has the little stop on the plastic piece to stop it. I believe it eventually turns off cause of a delay in it so it doesn't keep running. Then of course the reason why it doesn't go down until you push it is because there aren't any teeth in the gear of the motor.
 
K

·
Guest
Joined
·
0 Posts
Eric's right!! Mine made a noise but didn't move so I took out the very back panel(you have to, to get the side panel off) and the side panel that the antenna is behind. Pulled the tray out and my spare tire(so I could climb in my trunk better and just pulled a wire harness that ran into the antenna. There are two or three harness's but the one I pulled was the smallest one(i think it's on the front of the motor). That was my whole ambition to get up one Sunday morning, and it only took like 20 minutes.

Derrick
 
M

·
Guest
Joined
·
0 Posts
Would this be a good way to get the darn thing from going up and down needlessly every time my CD player turns on? It gets annoying to have my antenna going up and down all the time for no real reson... I don't listen to the radio anyhow
 
K

·
Guest
Joined
·
0 Posts
If you don't listen to your radio like I don't then I think it would be effective.

Derrick
 
1 - 6 of 6 Posts
Top