Mitsubishi 3000GT & Dodge Stealth Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
It’s been years since I drive my car. I followed the manual / and zeroed the maft out just to turn in the car and it’s a headache…. The car is flooded. I need help (payed if solved) please contact me
Jose Antonio
+584123323870
 

·
www.cts-racing.com
1999 Corvette C5 FRC, 1993 Stealth RT/TT
Joined
·
3,261 Posts
Two strategies are available here.

Recommend setting up the MAF-T to globally scale injectors and use SAFC to fine tweak on top of it.

What versions of each?
What size injectors?
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #3 ·
Two strategies are available here.

Recommend setting up the MAF-T to globally scale injectors and use SAFC to fine tweak on top of it.

What versions of each?
What size injectors?
Maft versión 2.02
Injector size 550
The manual said six 9, base 6, dip switch 1 on.. the car is flooded and barely has power..
 

·
www.cts-racing.com
1999 Corvette C5 FRC, 1993 Stealth RT/TT
Joined
·
3,261 Posts
Sounds like the MAF isn't working, box isn't wired in correctly, or potential fault with MAF-T. (Could also be a wiring issue to where maf signal isn't being communicated to ecu)

To troubleshoot, let's try just S-afc.

Try seeing if just the S-AFC settings will do it.

6 + arrow

Low/High Throttle say 30/65 %

-30 to -35% at idle rpm on low throttle. Car should start and idle not be rich. If not, then you for certain have a wiring problem somewhere or both are faulty (or ecu issue). Thus if the S-afc corrections work, diagnostics needed on MAF-t and sensor + wiring.

I'm assuming you are setup with draw thru and have everything hooked up.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #5 ·
Sounds like the MAF isn't working, box isn't wired in correctly, or potential fault with MAF-T. (Could also be a wiring issue to where maf signal isn't being communicated to ecu)

To troubleshoot, let's try just S-afc.

Try seeing if just the S-AFC settings will do it.

6 + arrow

Low/High Throttle say 30/65 %

-30 to -35% at idle rpm on low throttle. Car should start and idle not be rich. If not, then you for certain have a wiring problem somewhere or both are faulty (or ecu issue). Thus if the S-afc corrections work, diagnostics needed on MAF-t and sensor + wiring.

I'm assuming you are setup with draw thru and have everything hooked up.
Josh. The car was running all right with the maft zeroed out! The headache started when I followed the manual to six 9 and base 6.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #6 ·
Sounds like the MAF isn't working, box isn't wired in correctly, or potential fault with MAF-T. (Could also be a wiring issue to where maf signal isn't being communicated to ecu)

To troubleshoot, let's try just S-afc.

Try seeing if just the S-AFC settings will do it.

6 + arrow

Low/High Throttle say 30/65 %

-30 to -35% at idle rpm on low throttle. Car should start and idle not be rich. If not, then you for certain have a wiring problem somewhere or both are faulty (or ecu issue). Thus if the S-afc corrections work, diagnostics needed on MAF-t and sensor + wiring.

I'm assuming you are setup with draw thru and have everything hooked up.
Can I contact you via WhatsApp
 

·
www.cts-racing.com
1999 Corvette C5 FRC, 1993 Stealth RT/TT
Joined
·
3,261 Posts
Sorry I don't have that app.

With your settings you are telling me that:

You have a 3.5" MAF (yes?)

Aux = 9
Base = 6

That is correct for 550's.

Any blinking on the box?

From the instructions *


Troubleshooting

If the installation and tuning does not progress as the steps indicate, the translator signals can be checked according to the following table.



Wires to MAF sensor:

Pink - +12 volts

Yellow - MAF frequency signal

Black – ground (0 volts)



Wires to Vehicle:

Pink - +12

Green – Translator frequency signal

Black – Ground (0 volts)

Brown – ATS (Air temperature signal, fixed at 80 degrees)

Gray – BARO (Barometric pressure signal, fixed at 3.9 volts)

White – RPM signal, connected to CAS sensor.


No LED blink at key on: check power feed to Translator, check connections, check fuse.


RED LED is blinking: The MAF Translator has internal trouble codes that are blinked out using the RED LED. The codes are as follows.


1 blink - in RPM mode, No RPM signal

2 blinks – no MAF signal

3 blinks – Internal Flash memory problem.

4 blinks – dial or switch problem

5 blinks – internal program problem

6 blinks – problem with saved settings.

7 blinks – unit detected a reset while the engine was running.

8 blinks – internal Flash memory reset.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #8 ·
Sorry I don't have that app.

With your settings you are telling me that:

You have a 3.5" MAF (yes?)

Aux = 9
Base = 6

That is correct for 550's.

Any blinking on the box?

From the instructions *


Troubleshooting

If the installation and tuning does not progress as the steps indicate, the translator signals can be checked according to the following table.



Wires to MAF sensor:

Pink - +12 volts

Yellow - MAF frequency signal

Black – ground (0 volts)



Wires to Vehicle:

Pink - +12

Green – Translator frequency signal

Black – Ground (0 volts)

Brown – ATS (Air temperature signal, fixed at 80 degrees)

Gray – BARO (Barometric pressure signal, fixed at 3.9 volts)

White – RPM signal, connected to CAS sensor.


No LED blink at key on: check power feed to Translator, check connections, check fuse.


RED LED is blinking: The MAF Translator has internal trouble codes that are blinked out using the RED LED. The codes are as follows.


1 blink - in RPM mode, No RPM signal

2 blinks – no MAF signal

3 blinks – Internal Flash memory problem.

4 blinks – dial or switch problem

5 blinks – internal program problem

6 blinks – problem with saved settings.

7 blinks – unit detected a reset while the engine was running.

8 blinks – internal Flash memory reset.
Josh. I have 550s, no blinks. The car ran fine when it was zeroed. When I followed the manual and was setting everything (aux 9, base 6) i started having problems
 

·
www.cts-racing.com
1999 Corvette C5 FRC, 1993 Stealth RT/TT
Joined
·
3,261 Posts
Josh. I have 550s, no blinks. The car ran fine when it was zeroed. When I followed the manual and was setting everything (aux 9, base 6) i started having problems
When you follow the settings do you zero out the S-AFC?

What are the current settings to make it "run right"?
What's the current idle AFR or fuel trims?
Have you done a boost leak check? Have you confirmed you have 550 cc injectors and adequate fuel flow/pressure?
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #11 ·
When you follow the settings do you zero out the S-AFC?

What are the current settings to make it "run right"?
What's the current idle AFR or fuel trims?
Have you done a boost leak check? Have you confirmed you have 550 cc injectors and adequate fuel flow/pressure?
I have 550 injectors with good pressure…. I do think I have a boost leak, but as I said before. When I got the car with everything installed… car was running ok, not perfect, but had plenty of power…. At that moment, the Maft was zeroed out and the safc was -30 across the board. When I started to put the settings in the maft manual (aux 9, base 6) the car started to have this problems that till today it’s been a pain. If you give me your WhatsApp direct number Josh and you help me, I could even Pa you (and it’s not a good moment for me right now) I’m willing to do it. Please help
 

·
www.cts-racing.com
1999 Corvette C5 FRC, 1993 Stealth RT/TT
Joined
·
3,261 Posts
By scaling the MAF-T you should zero out the S-afc. If you have them both correcting you are doubling the correction. Try zeroing out the Safc with the MAf-T settings.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #13 ·
By scaling the MAF-T you should zero out the S-afc. If you have them both correcting you are doubling the correction. Try zeroing out the Safc with the MAf-T settings.
I’m desperate here. 8 years, eight years without driving the car. Just tell me what settings to put. What alternatives, options. Help please !!!
 
1 - 13 of 13 Posts
Top