Mitsubishi 3000GT & Dodge Stealth Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
343 Posts
Discussion Starter · #1 ·
I've been running the fuel pump bypass for a while now. Today the car just died on me. I could tell it was the pump because the logger would trigger the relay, but I couldn't hear the pump kick on. I checked the bypass, thinking it may have come loose, but it was fine. At a loss, I wired it to the 2/3 terminals and it fired up.



I just tried running it from the 5/2 again and it died. I don't quite understand what happened. Looking at the diagram, I can't tell what the 5 connector is supposed to do. It looks like connector/wire 3 is directly from the MFI relay and battery. Any have a clue where 5 comes from or what happened??????
 

·
Registered
Joined
·
296 Posts
Well,... from what I can tell.... it looks like that relay may have gone south on you. Either that or you have a bad ground and or flakey fuesable link.

I personally rewired mine. I didn't like the way the stock setup worked (too many trouble areas), so I by-passed that relay and installed a 30amp relay back at the pump with a direct connection to the battery. More or less the fuel pump 'hot-wire' mod.

Let me know if you need any help.
 

·
Registered
Joined
·
343 Posts
Discussion Starter · #4 ·
PitchBlack94 said:
Well,... from what I can tell.... it looks like that relay may have gone south on you. Either that or you have a bad ground and or flakey fuesable link.

I personally rewired mine. I didn't like the way the stock setup worked (too many trouble areas), so I by-passed that relay and installed a 30amp relay back at the pump with a direct connection to the battery. More or less the fuel pump 'hot-wire' mod.

Let me know if you need any help.
That's my guess. I just can't figure out how the number 5 connector fits in the circuit diagram.
 

·
Registered
Joined
·
296 Posts
Give me a few minutes and I'll let you know... you have a 92 VR4 right???
 

·
Registered
Joined
·
343 Posts
Discussion Starter · #6 ·
PitchBlack94 said:
Give me a few minutes and I'll let you know... you have a 92 VR4 right???
That's the one, 92.

I've looked and looked at the schematic, but it doesn't click with me. It looks like 3 come directy from the MFI relay/Battery. Where is 5 getting power from? Is it from the battery too?
 

·
Registered
Joined
·
296 Posts
Ok,... here's the deal....

3 & 5 are basically powered by the same hot in theory. Think of 1 as a triggered ground for 3 thus engauging the relay. When 1 is grounded voltage is passed from 5 to 4, and thus through the fuel pump resistor. When the ground is removed from 1 (by the ECU), voltage is passed from 5 to 2, and thus by-passing the fuel pump resistor and giving full voltage to the fuel pump.

So,... from what the schematic shows,.. and from a foggey memory of many many moons ago... 3 and 5 are tied together at some point and share the same positive voltage source.

Make sense?
 

·
Registered
Joined
·
343 Posts
Discussion Starter · #8 ·
PitchBlack94 said:
Ok,... here's the deal....


Make sense?
Yep. I guess I do know how to read schematics then. That's odd however. I can get power from 3 and very little from 5. That means a wire is partially broken that feeds 5.

This must have happened a few weeks back. I noticed my fuel trims started climbing through the roof and I sometime got knock at WOT. I pumped up the AFC and sometimes didn't have knock and sometime ran way too rich. I'm betting my voltage to the pump was off and on. More reason to rewire it.
 

·
Registered
Joined
·
296 Posts
Glad I could help. Let me know if you need anything.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top