Mitsubishi 3000GT & Dodge Stealth Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
253 Posts
Discussion Starter · #1 ·
I never thought this could happen to me after 3yrs in owning this car.In the engine bay I hear some kind of "zzzt" sound not when idle but when in motion.It sounds like I have some mesh in the exhaust outlet vibrating against the pipe.Kind of like an old cat with its insides(charcoal)moving around.At this instant it seems like I lost slight engine pwr.My mech drove the car and he claimed the noise was not the exhaust but from the engine.It idles normal.My question is, what are the symptoms of a spun bearing/valves?do you lose oil pressure during this?
I have an appointment with this other performance shop to diagnose this problem tomorrow.
If my emgine is gone, I would be a lost on this board for a while.If so I also plan on buying a crashed 3s at the dealers auction and just transfer all parts I need to this one.I also have people who would swap engines
for around $350.BTW, it starts normally.I will update tomorrow
http://www.geocities.com/henboy1/.temporarypreviewfile.html?947637399690

[This message has been edited by blkstealthpaid4 (edited January 11, 2000).]
 

·
Registered
Joined
·
507 Posts
I had a zzzt sound for a little while. It turned out that my timing belt idler bolt broke and the idler was captured in the plastic shroud. It was the teeth on the belt that was rubbing on the plastic. I stasrted it once too often and the idler came off completly. My timing went way out and I bent 10 valves. Consequently that broken bolt cost me a head job plus the timing belt, idler, waterpump and all that work. Be carful, If it starts going zzzzzt, TURN IT OFF and check your belt.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top