Mitsubishi 3000GT & Dodge Stealth Forum banner
1 - 8 of 13 Posts

· Registered
21 Posts
Discussion Starter · #1 ·
Need some help with my 1991 GTO
Fuel tank was filthy with stale fuel and the pump not working, flushed and cleaned the tank, refitted and installed a new 524 lph pump
ran it for a hour, took it for a drive the next day, drove for about 30 kms, then blew my clutch master cylinder ( found that I'd put a hole in the piston )
turned off while thinking how i was going to get home, went to start in gear fuel pump not working,
tilt tray home, thought might've been fuel pump relay, after arrival
worked out fuse number 12 was blowing when ignition turned on reds,
Did the ******* globe trick plugging in a globe into the fuse slot
unplugged fuel pump, turned on to reds each time, then mfi, fuel pump relay and when i unplugged coil the light went out
disconnected each coil pack one by one found the coil closest to the firewall triggering
ordered a new coil pack fitted today and exactly the same thing happens to the globe at fuse,
I removed the pump at one point and checked it was working okay out of tank, noticed the joining plug in tank had fuel around, there is a rubber grommet but still getting wet
Im not sure if matters,
It wasn't doing it before but with the coil pack unplugged, the MFI is repetitively clicking with the fuel pump plugged in,
disconnected the fuel pump, MFI clicks once on reds
I think maybe I'm dealing with 2 problems?
What do you think my chances are getting a new coil pack which is faulty
I might go swap coil packs around see if makes a difference
Clutch is all working now
Thank you for your help :)

· Registered
21 Posts
Discussion Starter · #3 ·
Hi Don,
your presumptions are correct,
As this all started with the clutch losing pedal wondering if it has done some damage under dash going to the floor crushed a wire?
It has an after market ecu and ignition system
after doing further tests today im further confused
found the centre coil was causing the bulb to light up took out centre coil, bulb doesn't light up now
When the fuel pump is plugged in now it is turning the MFI relay to a flasher relay continually clicking on off, removed pump tested out of tank wired just the pump no senders still same unplugged the pump and stops the mfi repetitively clicking, while it is clicking the bulb will flash on and off at the same time

Unplug the two connectors to the PTU, What is the PTU? power transfer unit? I'm not aware of this
the one connector feeding all three coils, and the connector to the condenser. Condensor? Air con condensor? or suppressor attached to coil pack bracket? i have an aftermarket ignition box under my coils

Turn key to run and see if fuse 12 blows. if it lights up it will blow so no need to put another fuse in it?


· Registered
21 Posts
Discussion Starter · #5 ·
Thanks for very helpful info Steve and Don
Have tested the MFI all working as per test
still it clicks if fuel pump connected

Ecu is Adaptronic select engine management e420d basic with a M & W Ignitions type ECU3 ill attach pics,

Cannot have fuel pump plugged in without the MFI relay clicking continuously on reds, bulb flashes (wouldn't blow fuse if inserted but i don't leave on long enough to do damage,)
Tried to crank doesn't make any difference, which is strange as i thought fuel pump only powered up while cranking or running
have unplugged condenser, coils and the ignition bulb goes out on Reds when i plug in coils it lights up bright will blow fuse straight away, disconnect centre coil and it doesn't light up, so Ive now got 2 blown coils as tried the last old one which was removed and it is still shorting lights up bulb brightly
I wondering if i unplug ecu if the mfi will click with the fuel pump plugged in?

I did read about the oxygen sensor shorting out blowing the fuse, but car is low and cant access atm


· Registered
21 Posts
Discussion Starter · #7 ·
has a lot of money spent on it, supposedly 20k on motor rebuild but i think past owner got ripped off, Standard turbo's
( and some of timing order was incorrect reversed i can show you the position of leads were if you know why they would swap them? )
She has a Go fast Bits controller so you can tune yourself, i haven't played with that as yet as it was running fine
Ecu has been spliced in leaving all original wiring intact as far as i can see, a bit messy under there

Coils are standard using standard wiring and plate, have a cheap digital multimeter, might need instructions lol
Fuel pump is all okay, i have plugged in 2 different ones while out in the boot ( when cleaning tank made a block off plate for tank, no wires are crushed at tank i double checked that yesterday )
and mfi still clicks like a flasher relay sounds like its fighting with another relay, i did change 2 capacitors in air con controls before mfi started clicking on off repetitively, will be unplugging that this morning,
Fuse 12 was 15 amp
Bob recently sent me the manuals
Fuel pump relay under the air box, not the MFI relay have tested MFI and working correct

· Registered
21 Posts
Discussion Starter · #8 ·
air con controls unplugged hasn't changed
Unplugged and cleaned socket at the 5 pin fuel pump relay under air box, tested with fuel pump plugged in and mfi relay only clicked once likes its suppose to do
Have a i got 2 buggered 5 pin fuel pump relays? or is there a test i can perform, it seems like this relay is fighting with mfi relay
unplugged ecu and still same repetitive clicks from mfi and bulb lights up flashing in sync with mfi clicking as was doing..
unplugged the 2 pin resistor near the fuel pump relay and the mfi repetitive clicks but the bulb does not flash or light up? I'm not sure what that means or my next step

· Registered
21 Posts
Discussion Starter · #10 ·
1. China 525lph Hellcat Walbro copy ( but i have a working walbro smaller pump i tested and the old smaller pump tested to do the same repetitive clicking while plugged in)
The 525LPH pump can flow anywhere from 15-120psi (the bypass valve is set higher than Walbro's previous fuel pumps, which were around 85psi). Final fuel pressure is determined by your fuel pressure regulator. Please note that this is an aftermarket fuel pump, and some modifications may be required to get it to fit. The overall size is very similar to Walbro's previous generation GSS340/GSS341/GSS342, however the base is slightly enlarged as shown in the pictures

I know where you are coming from that the pump might've drawn too much current and damaged something? ( i will be wiring up an add in relay soon to the pump and see if it stops the mfi repetitive clicking )

2. Standard 12 volt Blinker/parker bulb 21 watt

3.12.36 volts

4. I disconnected the whole ECU no plugs attached apart from vacuum line and yes MFI constantly clicking like a flasher relay
( Originally when i started to do testing it blew half a dozen 15 amp fuses as soon as you put on reds, with the globe in fuse 12 position it was not repeatedly clicking, initially only once on reds and again on crank whilst holding mfi so i could feel it ) not sure why it repetitively clicks now all the time on reds, im not leaving on reds for too long so to not do more damage

5.. it has an alarm and is working correctly like it has done for the past 7 years

6. all earths are in place and same as they have been since i bought it, no major work has been done on engine
although the exhaust was pulled out while cleaning the tank and repainted, there was a braided earth wire which had been on exhaust to body was broken and another terminal fitted and bolted back on bracket after repainting exhaust installing the Fuel tank
I'm wondering if a oxygen sensor is shorting?

7. All good
8,.All good

9. definitely clicking repetitively

10. all inspected and clean no burnt wires or loose connectors, all wires in perfect condition

11. "Currently" in pic was (2016) what the old firing order was before i swapped around to the stamps on coil bracket and it runs fine, 142536
i just mentioned that as the motor cost 20k to rebuild 7 years ago and they couldn't even put the timing correct,

Thanks for your help

· Registered
21 Posts
Discussion Starter · #11 ·
Okay Good news :p an added 4 pin relay temporarily at the fuel pump out of tank runs the pump and mfi doesn't click, I still have 1 coil taken off plate waiting on a new one to arrive
What other damage have i done?

· Registered
21 Posts
Discussion Starter · #13 ·
Thanks Mothsmoths,
My apologies for not getting back earlier
I had to google Forsters as not as popular over here since early 90's, they are going to try to repromote it, but I think Aussies are into Great Northern or the old Vb
Happy to buy you some nice beers tho

Once i got the new coil, she fired up all normally, i triple checked all wiring on all the related power source fuse 12, tested the mifi everything is fine beforehand
I have some funny noises coming from my injectors like tappet noises so hopefully I haven't done any damage, or maybe as i unplugged ecu may have lost tune
I have ordered a cable for my ecu to plug into a tuner mates laptop so will wait til that arrives so I know Im not running in too lean and going to do further damage
I'll keep this post updated, hopefully it helps someone else in the future :)
1 - 8 of 13 Posts