Mitsubishi 3000GT & Dodge Stealth Forum banner

1 - 20 of 201 Posts

·
B FeelGood
Joined
·
1,127 Posts
Discussion Starter #1
I am looking into purchasing another Vr4 and have found a nice one. I was told the only problem with the car is that the digital climate control display does not light up. The AC, heat, defrost etc. all function properly though. Does this sound like a fuse might be out or something more serious? Any ideas would help :)
 

·
Electrical Whiz
Joined
·
1,767 Posts
if the display is not working then it's a bad unit, unfortunately theres no fuse that pertyains just to the screen. The unit is easy to replace and not too expensive if you find someone parting a car.
 

·
Premium Member
Joined
·
3,921 Posts
Dude, buy it no problem, I had the same thing. I bought another unit off ebay. It didnt work either so i started thinking that it is maybe my cars fault. I gave it one more try. I went to my community college to some electronics teacher. He repaired it in 5 minutes. Its a matter of like one transistor (or however you call them).
 

·
Registered
Joined
·
1,833 Posts
My climate control screen doesn't light up either but from looking at where it's mounted it seems like it would NOT be too easy to pull it. I can't ever seem to find a write-up on removal and reinstallation, so can anyone who has done it please explain in further detail what all is involved?
 

·
Electrical Whiz
Joined
·
1,767 Posts
Syn said:
My climate control screen doesn't light up either but from looking at where it's mounted it seems like it would NOT be too easy to pull it. I can't ever seem to find a write-up on removal and reinstallation, so can anyone who has done it please explain in further detail what all is involved?
it's actually not bad, you need to remove the center vent by using two flathead screwdrivers to lift up the two metal clips inside the vent. once vents is out, theres is one screw holding the top of the unit in. next remove the pieces of plastic that separate the center console from the dash, they should just pop off. there are 2 screws back there, one on each side of the console, remove those screws and the unit will be free. in order to manuever it out, you may have to remove your radio and the climate control computer that is above the radio.
 

·
Super Moderator
Joined
·
4,475 Posts
Pull it apart and look for R-38. It may be burnt, and replace it with a 1ohm resistor.
 

·
Super Moderator
Joined
·
4,475 Posts
Bishi said:
Hey Dave, R-38 is inside the unit? I posted elsewhere before I saw this.

Yep on the back side of the display circuit board.
 

·
Registered
Joined
·
328 Posts
Well, $1.29 for 2 resistors, and the little man is back in action! Wonder what the Stealership would have charged for this. Thanks Dave. :)
 

·
I think my cars drunk...
Joined
·
4,558 Posts
the only 1 ohm resistor i could find at radioshack was pretty big (about 1 1/2" in length not including the legs) it was a 1ohm 10watt resistor

which ones did you guys get?

i ended up getting a 1k ohm 1/2 watt resistor in case thats what you meant instead, i haven't installed it yet however
 

·
Oh SNAP!!!
Joined
·
6,115 Posts
Syn said:
My climate control screen doesn't light up either but from looking at where it's mounted it seems like it would NOT be too easy to pull it. I can't ever seem to find a write-up on removal and reinstallation, so can anyone who has done it please explain in further detail what all is involved?
takes 10 mins to take out and another 10 mins to put back in...i have timed my self...i have even rebuilt them and a digital mitsubishi radio:)
 

·
Registered
Joined
·
9,450 Posts
Nice little info here. Someone should WIKI this piece of info.
 

·
Super Moderator
Joined
·
4,475 Posts
Rustang Cobra said:
the only 1 ohm resistor i could find at radioshack was pretty big (about 1 1/2" in length not including the legs) it was a 1ohm 10watt resistor

which ones did you guys get?

i ended up getting a 1k ohm 1/2 watt resistor in case thats what you meant instead, i haven't installed it yet however

Might be dimmer Too much work to put the wrong part in
 

·
Super Moderator
Joined
·
4,475 Posts
Just an fyi for the guys searching it's a 1ohm 1 watt resistor
 

·
Moderator
Joined
·
4,227 Posts
bah I already bought a "new" one :( I guess I should take a look at mine anyway maybe snap off some pics. I guess the real question is why does that resistor burn up...it would be interesting to measure the current at that point and see if the one in there can handle it.
 

·
Super Moderator
Joined
·
4,475 Posts
Toni said:
bah I already bought a "new" one :( I guess I should take a look at mine anyway maybe snap off some pics. I guess the real question is why does that resistor burn up...it would be interesting to measure the current at that point and see if the one in there can handle it.
Well it's probably acting as a fuse too. The aging of the other components and their increased current requirements could be the issue. Then again there's a bad cap history with mitsu. There's also more than 1 issue with these and the resistor doesn't fix all :(
 
1 - 20 of 201 Posts
Top