Mitsubishi 3000GT & Dodge Stealth Forum banner
1 - 8 of 8 Posts

· Registered
Joined
·
139 Posts
Discussion Starter · #1 ·
My dash lights just went out while I was driving at night, couldn't tell how fast i was going. Did I blow a fuse? The bulbs went out? "engine check", "OD off" and all those icons still work. I just don't have lights to my speedometer and RPM gauge. Thanks for any help. :)
 

· Registered
Joined
·
3,749 Posts
Possibly a fuse, or a short somewhere. If you have put in a different radio for your car, you may want to check your connections 'cause that could cause it as well.
 

· Registered
Joined
·
139 Posts
Discussion Starter · #3 ·
Now that you mentioned it, I did just recently installed a new stereo and new speakers. I don't think I wired anything wrong... They all work great.
 

· Registered
Joined
·
1,306 Posts
you probably dont have tail lights either, i believe they are on the same fuse.
 

· Registered
Joined
·
139 Posts
Discussion Starter · #5 ·
Uh oh.... :(.....Do you happen to know which fuse it is? Thanks.
 

· Perplexed
Joined
·
1,571 Posts
I know it doesn't sound right, but check the bulbs in your gauge cluster too. They very rarely go out at the same time, and for that very reason I drove around for a few days unable to figure it out. But I ended up just taking it out for the hell of it and whaddya know, two of my bulbs had burned out at the same time. Or, perhapse, one had burned out and I didn't notice until the other went out leaving me with no light at all. This was in my daily driver integra BTW, which has two main bulbs lighting up the cluster. I haven't had to check the ones in my 3Ss so I'm not sure if it's similar to what you are describing, but worth noting.
 

· Pro xfercase destroyer
Joined
·
6,262 Posts
Yeah, check the "Tail" fuse in the box by your left foot when sitting in the driver's seat. There should be a plastic cover over the fuses with a diagram of which fuse is for what.

If you've got no dash backlight illumination at all, its almost certainly that fuse. If you replace it and it blows again, re-check that you installed the stereo correctly and taped up any exposed sections of wire, etc.
 

· Registered
1992 3000GT SL 5/speed non turbo
Joined
·
23 Posts
I lost all my lights except for headlights and brake lights at night. I began to suspect something different when they went off on the way home at night and then came back on just before I got home. The electronics whiz at the dealer discovered it was a loose wire in the turn signal/ light control. Everything is working again. I have a 92 3000 GT SL.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top