Mitsubishi 3000GT & Dodge Stealth Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
147 Posts
Discussion Starter · #1 ·
Ok heres the problem. My clutch, which until today worked fine, is now going to the floor so easy one could blow on it. Then it does not pop back into the upright position. It just stays there for a second, as if held by a sticky piece of old gum, then slowly comes back up into position. Since this started happening it is increasingly hard to shift. I dont know what the problem could be. Maybe theres no presure in the lines. Because the clutch feels the same way your breaks do if you have air in your lines and need to bleed them. I dont know.....help?!?:(
 

·
Registered
Joined
·
101 Posts
Hey had the same problem a month or 2 ago.
check 2 things
1.) check the clutch fluid level. It's in the corner in the back of engine compartment drivers side.
2) see if the slave cylinder has any leaks or moist areas around the black accordian boot.
If the fluid level is low you got a leak some place. most likely.
you need to bleed the line to get her to pump up again like brakes. The bleeder is like underthe plentum on the pasengers side kind of under the thermosat housing area but tucked way under the motor.
My first thing to replace was the boot on the slave cylinder and the little piston inside. It comes as a kit . I think it's like 14.00.
But trust me it's a tight squeeeeeze to fix this dumb thing. and what I thought looked like a40 min job turned into a 2 hour job!
Hope this helps, at least it's a start.
xcellnt91 @yahoo.com
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top