Mitsubishi 3000GT & Dodge Stealth Forum banner
1 - 12 of 12 Posts

·
Premium Member
Joined
·
880 Posts
Discussion Starter · #1 ·
Hey guys,
How does everyone clean their engines? A couple months ago I tried to spray it with the hose and then my car just died. It would only stay running with jumper cables attached and as soon as you took them off it would die. I ended up having to buy a new battery. Anyways...how are you supposed to clean it. My whole car is spotless except for the damn engine is dirty as hell because I'm scared to do anything to it. Any ideas?
 

·
Registered
Joined
·
354 Posts
I always use Simple Green and Rags and a little bucket of water, seems to do the trick. Iv'e heard some horror stories about people spraying the bitch down....
 

·
chunsangp
Joined
·
3,556 Posts
What I do is just spray the Simple Green all over the engine bay
and let it soak for 5 minutes. Then I rinse off with the garden
hose. then I start my engine and let idle for 15 minutes.

Of course you have to cover up your intake. If water goes in
inside of spark plug, car wouldn't start up.

So did new battery solved your problem?? That's strange though..:confused:
 

·
Premium Member
Joined
·
880 Posts
Discussion Starter · #5 ·
Hey that before pic looks really familiar. Thats exactly what mine looks like right now. :rolleyes:

chunsangp, yea I put the new battery in and evrything was fine:confused: I still don't know what it did.


blk93stealthes,what kind of place did that? Like a detailing place or something? Looks like they did a good job, I'd definately pay $20.
 

·
3kgt Driver
Joined
·
3,505 Posts
blk93stealthes- that looks really good

anyone else have pics of their engine bay w/ Simple Green?
 

·
blk93stealthes
Joined
·
9,150 Posts
it was just a place that cleans and details cars by hand...i think it is normally a little more because my great uncle knows the owner and he brought me there
 

·
chunsangp
Joined
·
3,556 Posts
Simple Green worked best for me.

I have pic but it's too big so can't attach...
 

·
Registered
Joined
·
1,067 Posts
horror stories?? Well i guess i m one of the lucky ones...i spary down the whole engine bay everytime i was the car and use Simple Green every few months...never had ANY sign of a problem...hmmmmm, come to think of it, i ve always sprayed down every engine bay i ve ever had and never a problem...
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top