Mitsubishi 3000GT & Dodge Stealth Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
208 Posts
Discussion Starter #1
Hey Guys,
I've noticed about a week ago my car just won't go, meaning roars like crazy rpm shoots up, increase in speed very little,( no i'm not flooring it) and it doesn't go up the hill the same way it did before. am I just thinking theres something wrong, or do you guys have an ideaof what it is?
 

·
Got Boost?
Joined
·
4,242 Posts
Askanni said:
Hey Guys,
I've noticed about a week ago my car just won't go, meaning roars like crazy rpm shoots up, increase in speed very little,( no i'm not flooring it) and it doesn't go up the hill the same way it did before. am I just thinking theres something wrong, or do you guys have an ideaof what it is?
If the rpms are shooting up, but the car doesn't go(or barely goes)...well, that can only mean one thing: clutch is going bye bye.

Solution: Get a new clutch and your troubles will be over.
 

·
Lost Soul
Joined
·
6,235 Posts
I believe even the auto's have a clutch plate I could be wrong though. Somethings definately not right. Is there any hesitation or is just the rpms go up and the speed doesnt match it?

-Jeff
 

·
Running With Scissors
Joined
·
2,654 Posts
autos should have clutch packs, but if you just got the fluid and filter changed, I would suspect that. Keep it simple.
 

·
Registered
Joined
·
208 Posts
Discussion Starter #7
ok above I was saying how my car was acting strange, but rigth after I called Mitsu to bring it in to be checked out, it was driving perfectly, and the computer and road test come out clean. Isn't it weird?
 
1 - 7 of 7 Posts
Top