Mitsubishi 3000GT & Dodge Stealth Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
683 Posts
Discussion Starter #1
I vwas driving the other day and I hit a bump and the check engine light came on. all the electronics in the car reset ( like the radio went off). Today i was driving and the check engine light came on and the car stalled. so i took the car home to my house and i was going to drive it over to a local car shop, but i could not get the car to go. it just kept stalling and the power would vut out. Now it needs to be towed. the only mods i have done to my car that would affect anything might be and exhaust + intake. I don't have a stero system. I thought maybe it was the alternator.
help me out guys, im really pissed.
 

·
Registered
Joined
·
51 Posts
Something like that sorta happened to my car. Everytime I would go slow, or completee stop it would stall. The problem was we just put in a new battery and the cables were lose. The alternator might be the problem, but when mine went out on another car, nothing reset until after we replaced it. Check your cables and make sure there secure...maybe you need a new battery
 

·
Registered
Joined
·
683 Posts
Discussion Starter #3
just got a new battery this summer :rolleyes:
 

·
Registered
Joined
·
844 Posts
Check the alternator. Mitsu. should be able to dx. the problem. Good luck! Hopefully it isn't too costly.
 

·
Badassical Baddage
Joined
·
6,535 Posts
unclesam099 said:
check your battery cables, they're probably loose.
I 2nd that...happens to me a lot on my NA
 
1 - 6 of 6 Posts
Top