Mitsubishi 3000GT & Dodge Stealth Forum banner

Help me choose a clutch

  • Spec stage 5

    Votes: 0 0.0%
  • Some random Chinese twin disc

    Votes: 0 0.0%

  • Total voters
    10
61 - 80 of 97 Posts

·
Registered
1gen VR4 GTO. 4bolt block with forged crank. 15G hong kong hairdryers and supporting mods.
Joined
·
76 Posts
Something is up with that you should be able to blow past 15psi with stock wastegates.
I tested his wastegates (that came with the turbos) with hand. They felt really loose even compared to stock ones.

And with his T25 flange turbos the wastegate flap is bigger in diameter, and the flap arm is also longer. So I believe that with the same backpressure the bigger area of the flap valve generates more force, witch is multiplied with the longer arm of force, combined with weak wastegates would explain why backpressure is able to open the WG:s with lower boost that with stock turbos.

But yeah im just guessing.
 

·
Registered
Joined
·
51 Posts
Discussion Starter #62

Finally got new wastegate actuators. Can't install them yet tho, since there was a little problem with my set of $88 Chinese injectors. I have driven the car this sping with these injectors and the new set up for over 2000 miles and last year atleast 2500 miles without any problems. Two days ago one injector apparently got stuck, since the exhaust was filled with fuel and the engine was running on 5 cylinders. Everything seems to be working fine now tho, but I think I shouldn't risk the engine by continuing using these injectors. I have been saving for a new spec stage 5 clutch, but I guess that will also have to wait since genuine bosch 1300cc injectors cost around $600. At least they are available locally.

MOT coming up in two weeks, most probably have to dyno the car before that. And since the restrictions are being lifted in Finland it would seem that the first dragrace event of the season is being held at a local airfield in two weeks also. Hopefully I will pass the inspection before that. Still running the slipping ebay clutch of course, so I can't launch the car hard. Then again I could just send it and destroy the clutch :D
 

·
Registered
Joined
·
51 Posts
Discussion Starter #63 (Edited)
Finally installed new wastegate actuators, but only got around 1.25bars (18psi) of boost with 70% duty cycle on the boost solenoid. Should be more since I have 13psi springs in the actuators. Car also feels a bit laggy, since I only hit 18psi with third gear and high engine load. Must be a boost leak somewhere, can't hear it over the exhaust tho :D 18psi fealt even faster than before. While accelerating with 3rd gear didn't even realize I have to switch to 4th almost as quick as from 2nd to 3rd. I don't know if that makes any since but the car is fast and still more boost to come.

Gearbox is leaking oil somewhere pretty bad, guess it's soon time to remove and repair it again. Changing the synchro hub should be easy and rather fast. I'll have to get a new clutch at the same time but haven't decided what to get yet.

Other than these small problems the car is working great. Injector duty cycle is around 80% on 18psi, so I will soon run out of fuel. The loop connecting the two fuel rails seems really restrictive, so I will start by upgrading that to AN8 hard line. I will just weld -8 fittings to the end of the rails. Hopefully it will increase fuel flow and drop the duty cycle a little.



Drag event got canceled, no surprises there. Edit. Forgot to add that passed MOT.
 

·
Registered
Joined
·
51 Posts
Discussion Starter #64
The loop is ready, and wokrs great. Injector duty cycle dropped almost 10%. Didn't believe the loop would have such a big effect on it. Only down side is I will have to remake the loop since it hits the rear turbo boost pipe. Oops. At least I'm getting better at fabricating when I do every step twice.

Resealed the intake manifold gasket with gasket maker. One big boost leak less and I can tell that the car runs smoother and is more responsive. Nothing too major tho, I still think the 19ts should spool faster than 4k rpm. And with the boost control solenoid duty at 50% it still only produces 1bar (15psi) of boost. I think with the solenoid half closed the boost should be higher. Got to investigate more.


 

·
Registered
Joined
·
51 Posts
Discussion Starter #65
Found a big boost leak from the y pipe I welded up that connects the two turbos to the intercooler! Welds were leaking, guess I'm not as good welder as I thought. Car feels much more responsive and got around 1.3bars of boost (18psi).
 

·
Registered
Joined
·
156 Posts
Hi
and nice project you have there!

my first time drag race with stock ecu BPU mods were 13,9s and second time 13.1s

good luck guys, hope we see 10.xxs dd 3s car In Finland soon :cool:
 

·
Registered
Joined
·
51 Posts
Discussion Starter #67
Hi
and nice project you have there!

my first time drag race with stock ecu BPU mods were 13,9s and second time 13.1s

good luck guys, hope we see 10.xxs dd 3s car In Finland soon :cool:
Thanks! I'm hopeful too but it will take a while before I can afford a new clutch 😅
 

·
Registered
1gen VR4 GTO. 4bolt block with forged crank. 15G hong kong hairdryers and supporting mods.
Joined
·
76 Posts
Hi
and nice project you have there!

my first time drag race with stock ecu BPU mods were 13,9s and second time 13.1s

good luck guys, hope we see 10.xxs dd 3s car In Finland soon :cool:
Luckily if we are getting one 10 seconds GTO here, we are soon getting three ones as me, JKZ16A and my friend are together building these with almost the same upgrades. Who is the first will be the question.

Or then we will just run out of our money and quit :D
 

·
Registered
Joined
·
51 Posts
Discussion Starter #72
Lucky for you the injectors were stuck open and not closed.
And luckily I was only moving the car from one parking spot to another in front of our garage. I don't want to know what would have happened to my pistons had an injector got stuck closed while doing a pull.
 

·
Registered
Joined
·
51 Posts
Discussion Starter #73

Finally got to drive at the airfield last weekend! It was good fun and the car survived 8 passes, best being 12.8355 @187.5kph or 116.5mph. Last year with a fully stock car was 14.37 @151.3kph or 94mph.

Not as big improvement that I hoped (and thought) unfortunately. This is partly due to the ebay clutch that starts to slip if I launch the car too hard or slip the clutch while launching. The boost solenoid was also turned to 100% in the last passes and still only got 1.33bars (19psi) of boost. I have patched many boost leaks but it seems like I still need stiffer springs in the actuators. The spring is now 0,9bar, have to try 1.2bar springs next time. Should have ordered two port actuators and a 4 port boost solenoid for better boost control.

After getting back to the garage I noticed that the rear turbo wastegate had been stuck a little open the whole time. No wonder the car felt more laggy than before at the airfield, it was only making full boost at 6000rpm. Got it fixed and got the responsiveness back. I had trouble launching the car probably because of the slow spool, it almost felt that the car stalled at green light and only got 2.1sec 60ft's.

Everything is still working fine and I have little under 20% of fuel left from the stock fuel feed and return. Next up sorting the issues, probably disassembling the gearbox again, more boost and aim for 11's.
 

·
Registered
Joined
·
156 Posts
yep,

i had 11,803s / 189,55kph or 117,7mph (back in 2011)

was your 60ft 2,1sec on the best pass 12,8?

3500-4000rpm good launching rpm :cool:
 

·
Registered
Joined
·
156 Posts
you have to get your 60ft to 1,7-1,8s

then you have 11,xx time
 

·
Registered
Joined
·
51 Posts
Discussion Starter #78
Didn't have anything better to do today, so decided to take the gearbox out of the car for preventative maintenance before the next drag event. Little over three hours of work and the gearbox was out. Going to swap the 3rd and 4th gear slider hub for a better one, swap the forks and fork rods, and fix leaks. When I repaired the 5th & reverse fork last summer the rod was bent from heat a little, I'm thinking that is the reason why 5th gear grinds when shifting it fast. Hopefully the carbon fiber synchros aren't too worn.

At first I though not to look at the clutch and just repair the transmission but friend suggested to grind the surface of the flywheel and pressure plate. This would of course be the perfect time to replace the ebay clutch but unfortunately I can't source one this fast (planning to get the car running again at the start of the first week) and I also don't have money for a new clutch. Ebay clutch seems fine tho, it is just not able to hold hard launches. Maybe it will save my transfercase tho.

Hopefully I can get the gearbox working corretly and just swap out the clutch next time without having to disassemble the gearbox.

 

·
Registered
Mitsubishi's
Joined
·
72 Posts
Nice build so far. That clutch doesn't look bad, at least yet. Just inspect everything well for odd wear of fractures. Pressure plate is showing some hot spots for sure, but so long as its not chattering might as well run it.
 
61 - 80 of 97 Posts
Top