Mitsubishi 3000GT & Dodge Stealth Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,056 Posts
Discussion Starter #1
roger or Brian or anybody else,
I have an electronic boost controller and I dunno why the boost on 2nd gear drops down to 10 psi from 15 at about 5000rpm. is this normal? but then it maintains at 15psi on 3rd, 4th and so on...I was thinking that maybe my solenoids are not balanced and thus the car feels like it has no air and runs out of breath at about 4500rpm...before when I just got the car running stock solenoid, the car was damn fast unlike now....do you think is the wastegate? how can I perform a wastegate check? to see if they are closing properly...after 4500rpm on any gear it feels like the car has no breath (air) and that is working very hard...this shouldn't be so cuz it's a TT...I was thinking that maybe on of the turbos is not making 270cfm of air...and that only one turbo is working hard to maintain my 15psi...what do you guys think?
 

·
Registered
Joined
·
1,056 Posts
Discussion Starter #3
trevor,
but did you gut your cats and precats? I didn't. I have the ATR and HKS evc ez, 440cc injectors, fuel pump, afc2, dual friction centerforce clutch...I am just wondering if there is a sensor that's burned causing my car to feel like it's out of breath...after 4500rpm even with turbos at 15psi the cars feels like a n/a hehehe sort of...I have a 96. I thought that my cluctch was slipping but I realized that this was not the case cuz I spoke to Vr-4Tissimo and he said that his 1st gear at 7000rpm hits 41mph...which is the same as mine...so it's gotta be something with the engine management...a sensor? or is it that the wastegates are not calibrated or are letting to much exhaust escape? also, when I bought this car in 97 (stock). I took it to the dealer and had them look at the clutch cuz it was grinding on 2nd...ok I get the car back and the car was not as fast as I initially felt. then, I changed the motor oil and then took it for a spin. I step on the pedal and I saw the stock boost gauge hit 14psi and did feel like the turbos where kicking...but as you know the stock gauge is inaccurate but then suddenly I let go off the throtle and then I just step on it half way just so that the turbos spool up to 14psi (turbos already whistleling)when all of the sudden I hear a louder wistle (I did not move my right foot--it was in the same position)..then I feel the car THRUST forward!!! Real fast!!!! My brother was on the car and he too was scared...I think he was going to pi on his pants...
Anywayz, the car felt like it breathed so well and the engine was doing everything so effortlessly...but now even with the boost controller set at 15psi...the car feels like it's out of breath...and never felt that THRUSTING feeling anymore!!
I heard that somebody on the msgboard said that these cars are known to have problems with the wastegates or something related...PLEASE Help...I've been driving my car like this for the past 2 years! Brian or Roger or anybody who is adept in the subject
 

·
Registered
Joined
·
3,053 Posts
Brian has definitely more knowledge on such stuff but my first guess is that you are simply running way too rich in this area and this makes your car slower and you feel something like a light stumble and that it is runnign out of steam. This is true, because the engine is not getting enough air for the amount of fuel you want to give it. IMHO, the problem is tuning in the AFC at first.

Ok, it is also possible, that you are running into knock and the ECU retards the timing heavily without initiating fuel cut. The later is not initiated due to the fact that you are having larger injectors and the values from the fuel map are still valid (the pointer is not off the table)

In both cases, tunign in the AFC is necessary. Try to enrichen the mixture a lill more in the problem area. If the behaviour is getting worser, then go to the leaner side.

For the boost in second I may blame the cheap EBC and its setting for it. Under heavy, contignous load there are no quick boost changes and therefore the controller can act well. But in 1st and 2nd the changes are fast and the solenoid will then simply open too quick and then boost falls off too much. You'll be through the 2nd before the EVC can act. So I think it's the settigns you may change, less overboost and better reaction.
 

·
Registered
Joined
·
1,056 Posts
Discussion Starter #5
Roger,
thanks for replying here also...well, I have the HKS evc ez...so it's a simple way to control boost. it's set at 1.02bar. as far as the afc2, I tried to richen up the mixture and I ran into fuel cut when I was doing 1.08...but I recently I did a compression test and the psi on all pistons was 150psi...so everything is in order...I,now, run the afc with 10% leaner all across the 1k-4k rpm and about 8% from 5krpm-8k rpm...I don't really think that's the problem cuz the problem was there before the injectors, afc2, and all the other mods...I really don't know what to do roger...is there the posibility that the wastgate is being kept open and all the stress falls on one turbo? cuz that's how it feels like...a single turbo car although I can maintain 15psi on 3rd, 4rd, etc. anymore insights???? I really need help...and there is nobody who I really trust in the NY area...I guess I'll go down to dynamic racing if I can't find the problem...help me out roger will you?

thanks and take care!
 
1 - 5 of 5 Posts
Top