Mitsubishi 3000GT & Dodge Stealth Forum banner
1 - 6 of 6 Posts

·
i don't even know...
Joined
·
2,245 Posts
Discussion Starter · #1 ·
1. seems like i'm draining oil too fast
2. this week, total change in pitch, sounds like wind whistling through a tube from -10 to about 5psi, instead of that great sssssSSSSSSSS sound, also seems to be a loss in max boost levels
3. oil smoke now coming from the buttpipes when revving

doesn't sound good to me... any agreements? i haven't been able to pop off the IC pipes to check for puddling, it's been raining forever here... thanks

4. seems to be backfiring on shifts and letting off the gas more than usual... any relation or do i just have problems backing up?
 

·
20 yr owner
Joined
·
1,867 Posts
If your burning oil after the car warms up then chances are its turbo, as oil leaks from turbo in exhaust pipe.

You can also check for shaft play pretty easy on the compresser side of turbo.

Goin bad turbos usually burn more oil decending in rpm, or between shifting.
 

·
Registered
Joined
·
949 Posts
I've picked up that blowing/leaking air into no where sound too... oh god I hope not...
 

·
i don't even know...
Joined
·
2,245 Posts
Discussion Starter · #4 ·
Beast said:
If your burning oil after the car warms up then chances are its turbo, as oil leaks from turbo in exhaust pipe.

You can also check for shaft play pretty easy on the compresser side of turbo.
:( sigh... it's what i figured... thanks for the info

B_Davis sounds like you've got a little spinny problem too...
 

·
i don't even know...
Joined
·
2,245 Posts
Discussion Starter · #6 ·
well i guess she's dead... started her up this morning for the daily commute, and as soon as i got on the road she started blowing clouds of oilsmoke out the back, can't get any boost pressure at all, nasty sounds coming from the engine bay... not good
:( :( :( :( :( :( :( :(
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top