Mitsubishi 3000GT & Dodge Stealth Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
194 Posts
Discussion Starter · #1 ·
The backup (reverse) lights on my 1993 3000 arent working! The bulbs are fine, and after replacing the fuse the lights worked for a few seconds but are not anymore. Can anyone offer any help or suggestions? Thanks.
:confused:
 

·
Registered
Joined
·
194 Posts
Discussion Starter · #4 ·
It is a 1993, manual trans. The fuse isnt blown this time, its still intact. However, I did not replace it with the exact same fuse that was originally there. Could this have something to do with it too?
 

·
Registered
Joined
·
1,729 Posts
Well with fuses it will work with a higher amp fuse, but not with a lower. I don't advise using the wrong fuse. Since it is a manual, you can check the reverse light connector on the trans. It is on the top front of the transmission close to the passenger wheel. A simple wiring harness. It's pretty much blocked by the MAS you will need to remove the intake.
 

·
Registered
Joined
·
10,686 Posts
Replacing fuse with a larger fuse is a sure fire way to burn a wiring harness. My suggestion is to check the fuse with a meter to be certain that it is not blown. (Open fuses have been known to pass a visual test)

http://www.ecanfix.com/users/manualcd/gift/3s/3s_lighting_circuit.pdf

Page 34 of the PDF shows a wiring diagram. It's either the switch, connectors or the harness.


Clint
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top