Mitsubishi 3000GT & Dodge Stealth Forum banner

1 - 14 of 14 Posts

·
<3's lapping days
Joined
·
3,275 Posts
Discussion Starter #1 (Edited)
We had the first practice of the season today, what a blast! Took the VR-4. no changes since last year except the SCE brakes.

I worked first and drove 2nd, so I got to see about half of the course to see where people were having problems and how to navigate better. It was WET to begin with, cars were sliding everywhere, it was also very cold, probably high 30's. From 9:30 to 10:45 the first run group ran, then it was my turn. By the time our group hit the track it was beginning to dry up but my first run I was all over the place. I spun out pretty much the first turn of the course, lol. I got better and better throughout my runs but my final run was a 49.9xx, only a handful of people got into the 40's. One of the fastest drivers in the state was in a Pontiac Solstice and he ran a 47.xxx, he was fastest time of the entire morning session. I put on my exhaust cutout, it sounded awesome! It pulls for about 1000 more rpm, too. I never got past 5500 in 2nd gear.

I am running 255/40/17 Dunlop Star Spec Direzzas. The rear tires have like zero tread on the outer blocks, probably the reason I was so tail happy today. Tax return is soon, new tires INC....

Will post in car vids of all my runs when they get loaded into youtube, but for now here are the pics my dad took. He was using my moms point and shoot olympus, I dont know wtf is up with the yellow tint, lol.














This one is my new favorite pic of my car!



Super pimp doin his thing! haha

 

·
<3's lapping days
Joined
·
3,275 Posts
Discussion Starter #2 (Edited)
Saved for vids

Spin at the first turn of the year, YESSSS!! Ok so spinning isnt good but everyone was doing it, it was really cold and damp. I wish you could see how squirrely it really was, but the POV of the camera doesnt do it justice. Ran a 60.xxx

Run 1



No Spin this time!! Didnt spin but didnt do so well, either. Spun through 1st gear on the launch, kind of fun! The 2nd element after the first slalom section I missed a gate, came in too hot, didnt want to try and make it and cut a cone in half with my splitter.... Love the slide before the final turn around. Ran a 52.xxx

Run 2



Still having trouble keeping the rear end in check. Lost control at the same place I missed a gate from run 2. Sweet powerslide @ 1:36! Hit one cone in the first slalom. Ran a 55.xxx SLOW!

Run 3



Was a better run than my others, did a perfect trail brake at the first turnaround, its hard to tell through the vid but damn, it was awesome. 51.xxx

Run 4



Best of the day for me, just was a little more aggressive all around and especially the end, 1st gear powerslide and slammed 2nd gear, I am sure that shift if the only reason I made it into the 40's, i ran a 49.907. My dad and I were so damn exited. Wish I could get some footage of that slide from the outside :)

Run 5
 

·
4G63 swap initiated
Joined
·
7,359 Posts
sexy ass
 

·
Obsessive Carpolsive
Joined
·
2,090 Posts
Last turn was pretty tight dude! Yea def would like to see some outside vids
 

·
Super Moderator
Joined
·
21,160 Posts
Looks like fun man - what a big course! Mix of dry / wet pavement looks like it was a handful. Especially if your brakes were more touchy. Jealous you're out having fun already lol.
 

·
SDSU Alumnus
Joined
·
3,263 Posts
That last slide was pretty wicked! I seriously thought Seth Rogen was congratulating you hahah! No offense intended of course. Good job man.

Random thought - The Lancer looks weird/gross with two canisters like that. I have seen worse though. That is definitely not my cup of tea.
 

·
Registered
Joined
·
110 Posts
Sweet! Always nice to see a fellow 3/S autocrosser out there getting it done! :bigthumb: That course looked like a skating rink lol nice job keeping the power down! No wonder they say Washington state autocrossers are among the best in the rain...you guys probably deal with these conditions all year long!

We just had our first event of the spring season down here in the San Francisco Region today as well! Sold my V710s and track wheels and now running on the new Azenis RT615K's for the season to save time and effort switching wheels and get better at being smooth. Here's a couple of my non-screw up runs lol. The camera is pretty horrible and the weird lighting didn't help :(.


 

·
Registered
Joined
·
4,067 Posts
Looks so fun! Congrats on the times.

Are you usually in second? I have a 5 speed and my course is slower, but I'm either bogging a bit in second or touching the limiter in first..

Also, I wish I had issues with the back end kicking out instead of pushing lol!
 

·
<3's lapping days
Joined
·
3,275 Posts
Discussion Starter #10
Our course is generally 35-60 mph, so thats 2nd gear for a 6 speed.

The only times I needed to go down to 1st is the turnarounds, its around 25 mph so that quick 25-40 and then banging 2nd means 50 mph pretty quick.
 

·
<3's lapping days
Joined
·
3,275 Posts
Discussion Starter #12
I wish I had a glass sunroof, would be a perfect mount :/
 

·
I'm a Member
Joined
·
9,699 Posts
there are mounts on EBAY that attach to anything...or are you worried about not being able to push the go button?

I find that having the mount anywhere other than low on the front bumper really does not show what speed your actually doing...and I figure you want to feel the speed when your watching!
 
1 - 14 of 14 Posts
Top