Mitsubishi 3000GT & Dodge Stealth Forum banner

1 - 6 of 6 Posts

·
Hail to the King, Baby
Joined
·
1,064 Posts
Discussion Starter #1
I got a couple little annoying things my car (1995 SL) does.

1) Whenever I turn on the FM, the antenna extends and then buzzes for 20 seconds, like its still trying to go up...very embarassing. How do I fix this?

2) On my ECS, the only light that comes on is the 'sport' light, never the 'tour' light. When the 'sport' light isn't on, the area on my dash is just dark. This isn't normal, does it indicate some sort of problem? I can feel the difference between the two. BTW, the car always starts in the 'tour' mode, when I think it's supposed to start in whatever mode I turn it off in, could this also indicate some sort of problem?

3)My shift boot isn't held up all the way to the knob, apparently I'm missing some sort of plastic thingy-majig. Where can I get one?

Thanks, if anyone could help out i'd be much obliged
 

·
Senior Member
Joined
·
1,280 Posts
2) The ECS system does reset to tour when you turn the car off. If your sport light is not flashing at you I would say you have a burned out tour light.
 

·
Hail to the King, Baby
Joined
·
1,064 Posts
Discussion Starter #3
Thanks for the help! Screw the tour light I guess, sport is the one that matters, I need to get some sort of voice over ala robocop that says "Sport mode ON!" whenever I hit the button :D
 

·
Registered
Joined
·
727 Posts
If you have an aftermarket alarm then its that. The dude that installed mine somehow mixed the wire up and disconnected it not knowing it and I figured id say just fuck it and not bother. Its either that or a burnt bulb..
 

·
Registered
Joined
·
1,827 Posts
I had a 95 SL (a while ago) that did the same thing. Antenna too. The antenna I don't know what you can do about other than unplugging the damned thing (IMO, makes the car look like a radio controlled car when it's up anyway). As for the ECS light.... I found that going postal on my dash fixed it pretty quickly. I smacked it a few times, and it came back on. That's the way my steering wheel works too. Smack it, the radio lights turn back on and my horn works again. Also, the thingy that holds the shift boot on is a zip-tie. It's really kind of sorry, but I suppose it works. Just pop the center piece (the plastic that's around the base of the shifter it's self) and look underneath, probably just slipped off. Get a new zip tie, and tie it back down, or get a new neato shift boot instead. :)
 

·
Registered
Joined
·
832 Posts
1. Turn on the radio, after antenna is fully extended, cut the wire that tells it if the radio is on or off, this will make it stay up all the time. Or take it to someone who knows :D

2. Change the light, or go without.

3. Pull the base of the shifter boot out of place, move the top of it into the grooved area at the bottom of the shifter knob, use a zip strip or two (or bailing wire :D:D:D:D:D) to secure it.
 
1 - 6 of 6 Posts
Top