Mitsubishi 3000GT & Dodge Stealth Forum banner

1 - 10 of 10 Posts

Registered
Joined
6 Posts
Discussion Starter #1
Hi all I'm a new member but have been a visitor over the years. I am the original owner of a 99 SL, never had any real issues with the car. Recently I let ot sit for about a year as it was never a daily driver (only 60k mikes) Well I went to start fixing it up for my son as his 1st car...I know I know lol. But It will not start. Cranks but no spark on 3 & 6, coil & PTU are good, new red top battery...I'm stumped. Problem is I can't for the life of me find a service manual with wiring diagrams and a ECU pinout with troubleshooting guide 馃槖. Any help is appreciated.
 

Registered
Joined
6 Posts
Discussion Starter #3
Drain the gas and replace with fresh, there is a drain plug on the bottom of the tank.
Drain the gas and replace with fresh, there is a drain plug on the bottom of the tank.
Thx for the reply. Would that help the no spark on #3 & 6? The tank was treated before it sat, can't remember what treatment I used lol, but tried to be proactive. Also I have no RPMs on crank is this normal? I need to do the 60k service regardless but trying to troubleshoot before I sink all that cash in. Removed 2 top covers, timing correct, can't see any wire dmg and have voltage to cam & crank sensors.
 

Registered
Joined
6 Posts
Discussion Starter #4
FYI to anyone looking for a 99 service manual without paying $300,
emanualonline.com is a rippoff, purchased a 99 received 91. I do have the full 91 service manual if anyone needs it!
Haynes (to my surprise) also sold me a generic manual nothing to do with my model. At least they refunded.
The CD format floating around does not specify 99 either
 

Premium Member
Joined
5,854 Posts
I was gonna say go look for evidence of mice chewing on wire, but you said you don't see any wire damage.
 

Registered
Joined
6 Posts
Discussion Starter #7
What's the health of the engine ECU's capacitors? Are they still factory original?
Believe them to be fine, not sure but Believe 99 didn't have this issue, at least not a widely know issue. I can upload a pic in a bit. ECU still on drivers floor.
 

Registered
Joined
6 Posts
Discussion Starter #9
Believe them to be fine, not sure but Believe 99 didn't have this issue, at least not a widely know issue. I can upload a pic in a bit. ECU still on drivers floor.
Now that I look in the sunlight rather than artificial possibly the "staining" on the bottom of the board...
 

Premium Member
Joined
5,854 Posts
Those two large ECU capacitors are original, (round cylinders with a large + sign on them). From your pic I do not see any leakage. If you put your nose to it, and take a large whiff, I find a leaking capacitor will give off a bad smell, some say like bad sea food smell.

If it passes those tests, then I would leave them alone for now and look else where for your problem.
 
1 - 10 of 10 Posts
Top