Mitsubishi 3000GT & Dodge Stealth Forum banner

1 - 4 of 4 Posts

·
<3's lapping days
Joined
·
3,275 Posts
Discussion Starter #1
Coopkill and Wingnut helped me put in an SCE center diff and my dad also welded in the Pampena brace a few months ago and I FINALLY have made it to an autocross since the install. The car drives soooo much nicer than before, under steer is reduced by half from before and the car isnt tail happy at all, very easy to drive hard.

I finally got my alignment sorted out too, but it isnt an all out race alignment. -1.4 degrees up front but the rear has -2.4 and a couple mm of toe out. The rear end is STABLE, however.

The Ohlins coil overs are superb, I added one click to the rear after my first run and it was noticeable, the car handles great even at full weight (probably 4k even with me in it).

I only took one pic of my car at the track.



My first run was good, clean. 53.3. You can see some areas where I was already straightened out before making the next turn, these are the areas I could carry more speed on.
<iframe width="560" height="315" src="//www.youtube.com/embed/gcd_2KiBBkI" frameborder="0" allowfullscreen></iframe>

My 2nd vid was much better. The timing equipment screwed up and I didnt get a time but I figure somewhere in the 52's. I had a 200 lb passenger. The slalom after the C-box got screwed up and was placed wrongly. I still ran through it the way it was set up before but it was now a detriment to my time. The course stayed like this for the rest of the day. The slalom could now be taken R/L/R for an advantage. I didnt know this yet though.
<iframe width="560" height="315" src="//www.youtube.com/embed/WhAs4wRCSMc" frameborder="0" allowfullscreen></iframe>

3rd run was still tentative but a much better time, 51.8 and clean.
<iframe width="560" height="315" src="//www.youtube.com/embed/BfmvuZF6STA" frameborder="0" allowfullscreen></iframe>

This was my best run of the day, my last run didnt record but it was dirty anyways, I entered the C-box way too hot and took out 2 exit cones, lol. This was just a smooth fast run with warm tires. There are a few small mistakes in there though I could have improved on but I am no professional. 51.1
<iframe width="560" height="315" src="//www.youtube.com/embed/pdrweEP9W5M" frameborder="0" allowfullscreen></iframe>

I was spraying my sidemounts and intake manifold with a garden sprayer and icewater between all my runs. IC's would be 130's after a run and in the 60's before my next one. Same with intake manifold. I could half the end run temp of 160 before my next run with just a few applications of the water. Makes a big difference. i ran 13.5 PSI all day and never adjusted my tire pressures.

I noticed I still have front wheelspin, I didnt remember it on the track but apparently its still there :/ Sticky hot 255 Z2's still dont have enough grip for 9b POWAH!!
 
1 - 4 of 4 Posts
Top