Mitsubishi 3000GT & Dodge Stealth Forum banner

21 - 40 of 43 Posts

·
Registered
93 NA ATX 3000gt DOHC
Joined
·
1,917 Posts
just gunna get a vise for the one I currently have and switch pins and save for next time
When you compress plunger with vise to line up holes, do it slowly because compressing it to fast can cause internal damage.

I've even used small drill bit or allen wrench to act as pin before.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #22
Wish I thought about that dumb me tried a think paper clip bent it as soon as i took of pully
 

·
Registered
93 NA ATX 3000gt DOHC
Joined
·
1,917 Posts
FYI, you can click on three dots at top right corner of post and can select edit to make changes.
 

·
Turbo Dreaming
Joined
·
277 Posts
so ill start with what I have replaced then go to the story, cold air intake ,spark plugs, wires, ignition coils, , fuel filter, (vr4 fuel pump salvage, i had to replace whole gas tank insert was rusted to all hell) maf, iac , tps , injectors, 2 valves (had a bolt in intake valve on 6 ha.. that was fun) rear head gasket, (timing, water pump, all the stuff that comes with the kit) vacuum lines all 3? Or 4 of them.. don't remember exactly atm, ok so, when I got this car I knew it was a project, however Im plumb out of ideas, checked compression on the valves replaced : 105 cold, so what started me on this wonderful journey is the car just has no power at all, its bogged down all the time from 0 to 3000 rpm after that takes off, I step on the gas and it really struggles either for air or fuel cant figure it out, video to before doing injectors ;

I've been told a misfire, rats nest in exhaust, the exhaust has a leak at 14in flex

Any advice would be grateful, and no I don't have a datalogger, stupid freak hybrid ecu.. also had a thought is it possible to switch to a 95-96 ecu?
I had a similar issue in mine. Have you replaced the PTU?


I am still waiting on my part since I just placed the order. The mechanic working on my SL told me it's definitely the PTU. I ordered mine with the coil pack from 3sx so I can get the warranty. As far as the ecu, I know it's expensive, but why don't you just order yourself a jester chrome ecu from 3sx? I replaced my old ecu with that one. I plan to keep my SL on the road for at least 5-10 more years, so I didn't think that it was a bad idea replacing it. I'm too stubborn and lazy to get a newer car.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #27
I had a similar issue in mine. Have you replaced the PTU?


I am still waiting on my part since I just placed the order. The mechanic working on my SL told me it's definitely the PTU. I ordered mine with the coil pack from 3sx so I can get the warranty. As far as the ecu, I know it's expensive, but why don't you just order yourself a jester chrome ecu from 3sx? I replaced my old ecu with that one. I plan to keep my SL on the road for at least 5-10 more years, so I didn't think that it was a bad idea replacing it. I'm too stubborn and lazy to get a newer car.
I have been thinking about it, I just got my new timing tensioner and the tool, unfortunately it was Chinese crap tool pins broke before it was tight so gotta go find one locally, after I do timing I may replace both, I really want to get rid of the 94 obd hybrid such a pain in the arse, after timing ill check compression, hoping I don't have to pull the head again..
 

·
Registered
Joined
·
34 Posts
Discussion Starter #29
Well next time this has to be done I ain't doing it, it seems impossible to get all 5 dots to line up at the same time
 

·
Registered
93 NA ATX 3000gt DOHC
Joined
·
1,917 Posts
Well all reassembled and this is what i got I cant get the front and back cans to stay on dot.. sorry last 2 are blurry cant focus up close
What you got in the pictures is OK, depending on different belts sometimes you can’t get any closer. Did you rotate engine two full turns clockwise and check again, as is suggested when checking grenade pin is still loose? Might even find cams closer when you do that and remember you can’t back crank up to mark to check anything.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #31
What you got in the pictures is OK, depending on different belts sometimes you can’t get any closer. Did you rotate engine two full turns clockwise and check again, as is suggested when checking grenade pin is still loose? Might even find cams closer when you do that and remember you can’t back crank up to mark to check anything.
Yes I did, so half a tooth off is ok?
 

·
Registered
Joined
·
34 Posts
Discussion Starter #32
I read that setting the crank back 1 should get them all to line up after tensioning, well did that ended 4 off, calling it a day for today cams bit me to many times lol
 

·
Registered
Joined
·
34 Posts
Discussion Starter #33
Currently disassembled again, kept trying to get it perfect.. way to aggravating
 

·
Registered
93 NA ATX 3000gt DOHC
Joined
·
1,917 Posts
Currently disassembled again, kept trying to get it perfect.. way to aggravating
I think if you just rotate two full turns clockwise and try to get crank on mark without over shooting, you’ll find they will be closer but you might have to tighten tensioner more to get pin where it feels free.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #35
I think if you just rotate two full turns clockwise and try to get crank on mark without over shooting, you’ll find they will be closer but you might have to tighten tensioner more to get pin where it feels free.
Alright ill try it later ill keep you posted
 

·
Registered
Joined
·
34 Posts
Discussion Starter #36
I think if you just rotate two full turns clockwise and try to get crank on mark without over shooting, you’ll find they will be closer but you might have to tighten tensioner more to get pin where it feels free.
This is where I'm at rotated reset tensioner after, gotta tight it again but waiting the 5 min
 

Attachments

·
Registered
93 NA ATX 3000gt DOHC
Joined
·
1,917 Posts
This is where I'm at rotated reset tensioner after, gotta tight it again but waiting the 5 min
I think when you get tensioner set to where after rotating, the grenade pin is still loose you’ll be close enough (best you can do).

The straight on shot of crank cog looks like it’s a little over travel and so does cams, but cams from back to front seem to be increasing in over travel which kind of indicates slack is not completely out of belt.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #38
I think when you get tensioner set to where after rotating, the grenade pin is still loose you’ll be close enough (best you can do).

The straight on shot of crank cog looks like it’s a little over travel and so does cams, but cams from back to front seem to be increasing in over travel which kind of indicates slack is not completely out of belt.
Yep I got it, pretty spot on now, how ever I guess the next issue is now it idles great at 1000, however when I step on gas it bogs down but when released it picks up in rpms, in thinking the vr4 fuel pump may not work out and or fuel pressure reg...
 

·
Registered
93 NA ATX 3000gt DOHC
Joined
·
1,917 Posts
Just out of curiosity, did you set TPS correctly as per manual when you replaced it?

Does it still sound same now revving as before in video?

Might also try unplugging the MAF, to see if it makes any deference good or bad.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #40
Just out of curiosity, did you set TPS correctly as per manual when you replaced it?

Does it still sound same now revving as before in video?

Might also try unplugging the MAF, to see if it makes any deference good or bad.
Actually no on tps.. gotta look that up I guess
 
21 - 40 of 43 Posts
Top