Mitsubishi 3000GT & Dodge Stealth Forum banner

1 - 20 of 43 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
so ill start with what I have replaced then go to the story, cold air intake ,spark plugs, wires, ignition coils, , fuel filter, (vr4 fuel pump salvage, i had to replace whole gas tank insert was rusted to all hell) maf, iac , tps , injectors, 2 valves (had a bolt in intake valve on 6 ha.. that was fun) rear head gasket, (timing, water pump, all the stuff that comes with the kit) vacuum lines all 3? Or 4 of them.. don't remember exactly atm, ok so, when I got this car I knew it was a project, however Im plumb out of ideas, checked compression on the valves replaced : 105 cold, so what started me on this wonderful journey is the car just has no power at all, its bogged down all the time from 0 to 3000 rpm after that takes off, I step on the gas and it really struggles either for air or fuel cant figure it out, video to before doing injectors ;

I've been told a misfire, rats nest in exhaust, the exhaust has a leak at 14in flex

Any advice would be grateful, and no I don't have a datalogger, stupid freak hybrid ecu.. also had a thought is it possible to switch to a 95-96 ecu?
 

·
Registered
Joined
·
34 Posts
Discussion Starter #2
Also now its always D with gas even in N after doing injectors
 

·
Registered
93 NA ATX 3000gt DOHC
Joined
·
1,916 Posts
I don’t have any suggestions at this point but since no one else has made comments, I’ll start with some questions that might help anybody to offer suggestions.

1) Are you sure crank cog gear and cam gears line up to their marks?

2) What size injectors did you install?

3) Are you sure plug wires match from coils to correct cylinders?

4) What does “D” stand for in your second post?

5) Do you have a multi-meter and know how to use it?
 

·
Registered
Joined
·
34 Posts
Discussion Starter #4
Timing im not 100% sure on the crank but here's a pic of where I set it, the gears were lined up

Oem injectors

Yes the ignition is correct however I noticed today one of the lining in the coil looked tarnished rest are bright

Drive

Yes for the most part I have a basic multi meter
 

Attachments

·
Registered
93 NA ATX 3000gt DOHC
Joined
·
1,916 Posts
Timing im not 100% sure on the crank but here's a pic of where I set it, the gears were lined up
There’s your first problem crank is advance by one tooth, that certainly will cause running issues and would cause low end torque problems. Because when crank hits top deed center all your cams are retarded.

Looks like you lined up balancer roll pin to mark on oil pump, instead of tooth with dot on top which is what you need to do.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #9
Ok thank you, ugh tare down tomorrow totally not looking forward to this again.. lol
 

·
Registered
93 NA ATX 3000gt DOHC
Joined
·
1,916 Posts
You’re welcome. Also you said OEM injectors does that mean for a NA or TT car?
 

·
Curmudgeon
Joined
·
5,454 Posts
It looks like you have a fair amount of goop in there as well. You might want to check that your main seal and/or cam seals are not leaking...
 

·
Registered
Joined
·
34 Posts
Discussion Starter #14
76k miles probably hard miles been sitting for 2 years before me, there's alot to do on this car lol trying to restore wish it was a vr4 but then again probably a good thing it isnt.
 

·
SDSU Alumnus
Joined
·
3,194 Posts
Even for cold, that compression test number is low - may or may not improve much when warm. What were the readings for all cylinders? You may want to perform a cylinder leak-down test after you redo the mechanical timing.

3SWIKI - Engine: Compression Test << for reference
 

·
Registered
Joined
·
34 Posts
Discussion Starter #16
All of the others when I found the messed up valve were 130 low side 170 high side mix between on all, only tested my work, maybe didnt lap the valve enough..first time doing it
 

·
Registered
93 NA ATX 3000gt DOHC
Joined
·
1,916 Posts
Did setting crank/cam timing help your running problem?
 

·
Registered
Joined
·
34 Posts
Discussion Starter #19
Couldn't find the pin for tensioner, so ordered a new one will be here in a couple days hopefully
 
1 - 20 of 43 Posts
Top