Mitsubishi 3000GT & Dodge Stealth Forum banner

1 - 20 of 69 Posts

·
Registered
Joined
·
500 Posts
Discussion Starter #1
Alright guys, so here's my story. I have my boost set to 16 psi and it was dropping consistently after 4500 rpm to 12 psi by redline. I had boost leaks in my throttle body which I recently fixed. I thought the problem was solved but I still can't hold till redline. I drop to about 13.8 psi so it's gotten better but still not 100% resolved. I have an evap smoke machine which I use to test for the leaks. My question is this. I have the stock exhaust with an aftermarket downpipe which replaces the main cat and one of the precats. One of the precats is still there. Could this be my problem?
 

·
4G63 swap initiated
Joined
·
7,360 Posts
Make sure your wastegates are preloaded properly
 

·
Registered
Joined
·
500 Posts
Discussion Starter #3
I thought preload just affects spool times.
 

·
Registered
Joined
·
4,353 Posts
Pre-cats are a massive restriction at higher rpm/ load.
 

·
Registered
Joined
·
4,814 Posts
Which 13G's are these? there are many types, the biggest reason why our car's can't hold full boost at redline is more the turbine size, then the compressor wheel, but the size of the compressor wheel doesn't help either.

There also if you have Euro13Gs , that won't hold full boost to redline either.
 

·
Registered
Joined
·
4,353 Posts
My UK spec turbos (11g?) Held 16psi to redline, spiked up to 26psi lower down the revs.
 

·
Registered
Joined
·
500 Posts
Discussion Starter #7
Which 13G's are these? there are many types, the biggest reason why our car's can't hold full boost at redline is more the turbine size, then the compressor wheel, but the size of the compressor wheel doesn't help either.

There also if you have Euro13Gs , that won't hold full boost to redline either.
I believe they are just the tdo4 13g's. I bought them new off of a guy on the forums back in 2004.

Another thing I notice whether it is related or not is if I hold my foot half throttle and it boosts to like 7 psi, as the rpm increases it will also drop by redline.
 

·
4G63 swap initiated
Joined
·
7,360 Posts
Could be clogged or rotted precat but doubtful. No i couldnt go over 14psi when my wastegates were messed up.
 

·
Registered
Joined
·
500 Posts
Discussion Starter #9 (Edited)
Yeah, my precat isn't clogged. I'll gut it out anyway and see if it makes any difference. What about the MBC?
 

·
Registered
Joined
·
204 Posts
Have you ever been able to hold more boost than that to red line or has it been like that since you installed them?
 

·
Registered
Joined
·
500 Posts
Discussion Starter #11 (Edited)
Have you ever been able to hold more boost than that to red line or has it been like that since you installed them?
I was able to hold 13 to redline I never went above that. I've put only about 6,000 miles on the turbos since I've had them. I noticed the drop off after i installed the cx racing front mount intercooler and increased boost to 16 psi but I dont have any leaks anywhere in the system. I'm starting to think it may be the turbos also.
 

·
Registered
Joined
·
204 Posts
I know you used the evap to test for leaks but does that also pressurized the system at the same time? If not you may have a leak that only appears after you hit a certain pressure
 

·
Registered
Joined
·
500 Posts
Discussion Starter #13
I know you used the evap to test for leaks but does that also pressurized the system at the same time? If not you may have a leak that only appears after you hit a certain pressure
Yes, it fills up the entire intake system with smoke. If you pull of any vaccum line you will see smoke coming out of it.
 

·
Registered
Joined
·
500 Posts
Discussion Starter #15
I was able to find all my throttle body leaks with the smoke machine. I figure if a seal is bad it's gonna leak rwgardless but ill try the pressure tester to confirm.
 

·
Registered
Joined
·
500 Posts
Discussion Starter #16
Well I set my boost to 10.5. After 4500 rpm it would alternate up and down between high 10 to 9 but it showed 10.9 at red line so it looks like it's holding
 

·
Registered
Joined
·
500 Posts
Discussion Starter #17
Well guys I smoke tested again and I found 2 leaks. One of them is from the greddy BOV out of the nipple that isn't supposed to be capped. I'm confused because you are not supposed to cap it. Do you guys think I should cap it?

The other spot was out of the braided vaccum hose that connects to the front waste gate actuator. It was smoking right through the middle of it. Anyway, I changed that hose but I can't do any 3rd gear pulls because of the rain. Hopefully it will be dry tomorrow.
 

·
<3's lapping days
Joined
·
3,275 Posts
What is your boost control method?
 

·
Registered
Joined
·
500 Posts
Discussion Starter #19
First it was a ball and spring MBC. Now I switched to AEM tru boost.
 

·
4G63 swap initiated
Joined
·
7,360 Posts
Your wastegate diaphragm might be torn, but you should pressure test.

Some people use the smoke machine in combination with a pressure test to have a visual rather than trying to track down a hiss with a squirt bottle of soapy water.
 
1 - 20 of 69 Posts
Top