PSA: How bad are your fuel injectors? Get them cleaned! - 3000GT/Stealth International Message Center
3000GT/Stealth International 3000GT/Stealth International
 

» Auto Insurance

» Featured Product
» Wheel & Tire Center

Go Back   3000GT/Stealth International Message Center > Modifications and Technical Support > Engine - Turbo

3SI.org is the premier Mitsubishi 3000GT Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 09-07-2019, 02:57 PM   #1 (permalink)
Forum user
 
jrhorne's Avatar
 
Join Date: Jun 2016
Location: Southern California
Drives: 91 3000GT VR4
jrhorne is an unknown quantity at this point
Feedback Score: 1 reviews
Default PSA: How bad are your fuel injectors? Get them cleaned!

I thought this might be an interesting read for some people, so I thought I would share my experience with getting my injectors flow tested and cleaned, what issues I had before, and how the car is performing now.

For the TLDR crowd: I was chasing knock issues at only like 6-7psi for a year or two on pump 91. Could not figure out the source and could never drive the car hard or really go into boost at all. Car never had this issue in the past (5+ years ago) when it was dyno tuned with exact same mods/setup. Tried adjusting tune on SAFC2 (more or less fuel) to no avail. Put in race gas and knock went away, confirmed fueling issue. Pulled injectors and had them flow tested and cleaned – see pictures below to see how horrible they were before. One or more cylinders running lean and the horrible spray pattern was causing the knock.

Backstory:

Over the past several years I felt like my 91 VR4 was getting progressively slower and the acceleration was not nearly as smooth as it used to be. Noticeable in all driving conditions but particularly in WOT. In WOT it would misfire sometimes and stutter. I tried doing plugs/wires and it fixed what seemed like some of the spark blowout when at ~12psi, but even when I turned the boost down the WOT pulls did not feel smooth and the car just didn’t pull like it used to. I did a compression test when doing plugs/wires and it was 160-165 across all cylinders. Oil analysis from BlackStone labs didn’t show anything abnormal, so I was pretty confident the engine was healthy.

About a year and a half ago I installed BlackStealth’s CANBUS converter and started monitoring ECU parameters and logging using Torque. With that huge jump in datalogging/monitoring capability I realized that I was getting massive amounts of knock even at 6-7 psi (literally max knock of 26). Keep in mind I am on pump 91 from California, so not the greatest gas. AFRs at this time were in the mid to high 10s at WOT. As soon as I realized the knock issue, I stopped driving the car hard. It was my daily at the time and drove OK under light to medium throttle so I put off doing anything major until recently when I got a new daily. Coupled with the knock was the ECU pulling timing under hard acceleration, which explained why it felt so slow and was stuttering when trying to do WOT (even after replacing plugs and wires to fix spark blowout).

Fastforward a bit and after doing some research I decided to run the tank to empty and put in 5 gallons of 100 octane gas. This turned out to be a very useful method to determine if my knock was fueling related (thanks to reading some posts on here about that test). As soon as I did that, the knock went away. Turned the boost back up to ~12psi and confirmed – no knock. AFRs were unchanged at mid to high 10s. I was pretty convinced at this point that the injectors were the source of my problem. The important thing to remember is that a WBO2 is basically just an average AFR across all cylinders… it doesn’t really tell you what is happening in each one (assuming you have only 1 installed, of course).

Once I finally got the time, I decided to bite the bullet and pull the injectors. Thankfully RC Injectors is only about a 45 min drive from where I live. So, I pulled the injectors, dropped them off to be flow tested and cleaned, and picked them up a few days later to reassemble the car the next weekend. I was pleasantly shocked at how horrible the before flow test results were; see pictures at the end of this post. Basically, the worst injector was 224 cc/min and the best was 506 cc/min. This amount of difference between injectors was clearly causing some inconsistent fueling among the different cylinders and explained my knock problem that surfaced overtime and got progressively worse. Also, the spray patterns were horrible – 4/6 injectors were “dripping”. So much for atomized fuel spray.

After installing the injectors the car fired right up again and sounded better than ever. Understandably I had to pull some fuel across the RPM range using the SAFC2, but the car pulled hard once I got the tune adjusted. Coupled with the 0.026’’ NGK copper plugs I just installed, all of my fueling and spark issues were gone. Finally, the car would run as it should under WOT. I have boost set at only around 12-13 psi right now but the car feels as fast as it ever has.

I am running about a 60/40 mix of pump E85/91 and the car is really happy there. I don’t think I will go any higher E content since I don’t want to run out of fuel pump (Denso pump) and I like maintaining a little negative correction on the SAFC2. Right now I am at roughly 15% negative in the low settings and 10% in the high settings (varying a bit a different RPM points).

Overall, I suspected injector issues for over a year and am very pleased with the results of getting them cleaned. The car runs great, and definitely safer with even fueling across all cylinders. Datalogs look great. More boost coming soon…







__________________
Gt-347 Turbo Kit (~13g)--RC 550cc Injectors--Denso Fuel Pump--Apexi S-AFC II--Turboxs Boost Controller--3sx Air Filter--DNP Stainless Intake Pipe Kit--Turboxs BOV--Autometer Boost Gauge--AEM UEGO Wideband O2--EK2 Downpipe--Gutted Precats--Testpipe--Polished VR-4 Plug Wire Cover, Valve Cover, & Plenum--Stage 2 Twin Turbo Clutch Kit--Full Bomex Body Kit
jrhorne is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  3000GT/Stealth International Message Center > Modifications and Technical Support > Engine - Turbo

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the 3000GT/Stealth International Message Center forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Free email addresses do not work(yahoo, hotmail, gmail,...)
We are currently being blocked by AOL so any AOL based address may not work(aol.com, aim.com, netscape.net, cs.com)
Email Address:

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 10:47 PM.



Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.