3000GT/Stealth International 3000GT/Stealth International
 

» Auto Insurance

» Featured Product
» Wheel & Tire Center

Go Back   3000GT/Stealth International Message Center

3SI.org is the premier Mitsubishi 3000GT Forum on the internet. Registered Users do not see the above ads.
3000GT/Stealth International Message Center

3000GT/Stealth International Message Center (https://www.3si.org/forum/index.php)
-   Engine - Turbo (https://www.3si.org/forum/forumdisplay.php?f=35)
-   -   Ok now... weird issue (https://www.3si.org/forum/showthread.php?t=817695)

KaraLs1 04-04-2019 06:41 PM

Ok now... weird issue
 
So car was running great. Great oil pressure just couldn’t be more perfect. All of a sudden running rough but when I gassed her in neutral the break pedal would be come so stiff. In fact when it started running rough the break pedal was stiff. But when I gave her gas in neutral the gas pedal wouldn’t push down at all..

HOSS 04-04-2019 06:50 PM

Re: Ok now... weird issue
 
for the brake issue check the vacuum at the brake booster to see if there is any.
the rough running is a whole other issue
start with checking for boost leaks

KaraLs1 04-04-2019 07:02 PM

It was running super good for a change then it started acting up and the brake was hard to push. Every time we fix something, something else breaks haha. 191k what can you expect. I have a 92 sitting in the garage with 112k and a bad engine

KaraLs1 04-04-2019 07:03 PM

Quote:

Originally Posted by HOSS (Post 1056298353)
for the brake issue check the vacuum at the brake booster to see if there is any.
the rough running is a whole other issue
start with checking for boost leaks

How do we check for boost leak?

HOSS 04-04-2019 07:28 PM

Re: Ok now... weird issue
 
lol you probably have more issues than just boost leaks with that age and mileage car you will have to locate the search button for the boost leak test GL

PhailosaurusRex 04-05-2019 06:45 AM

Re: Ok now... weird issue
 
Quote:

Originally Posted by KaraLs1 (Post 1056298351)
So car was running great. Great oil pressure just couldn’t be more perfect. All of a sudden running rough but when I gassed her in neutral the break pedal would be come so stiff. In fact when it started running rough the break pedal was stiff. But when I gave her gas in neutral the gas pedal wouldn’t push down at all..

Are you sure this is correct? The throttle is cable driven so if you can't press the pedal something is physically blocking it.

The break booster is vacuum assisted, if the hose going to it has come off or torn the pedal will become very still and you will have a large vacuum leak which could cause the engine to run poorly.

There are a number of ways to check for boost/vac leaks. Because I haven't bought the proper tool I stick a garbage bag between the filter box and intake pipe in front of the MAF to seal it. Then I dial down the regulator on the shop compressor and hook up to one of the vacuum lines, usually the clutch booster reservoir hose, pressurized the system and listen for leaks.
There might be a better way but that works for me.


All times are GMT -5. The time now is 12:29 PM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 12:29 PM.



Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.