3000GT/Stealth International Message Center - View Single Post - 2 Year Build Almost Complete with a question?
3000GT/Stealth International 3000GT/Stealth International
 

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   3000GT/Stealth International Message Center

3SI.org is the premier Mitsubishi 3000GT Forum on the internet. Registered Users do not see the above ads.
View Single Post
Old 04-15-2019, 12:13 PM   #2 (permalink)
bboyalan
SDSU Alumnus
 
bboyalan's Avatar
 
Join Date: Nov 2006
Location: CV/SD, CA
Drives: VR-4, EVO VIII & X
bboyalan Level 1bboyalan Level 1bboyalan Level 1
Default Re: 2 Year Build Almost Complete with a question?

If you are referring to the factory center gauge, then that is actually oil pressure. Assuming that both factory sending units are installed and no warning "dummy" light has illuminated on the cluster, then try cleaning the connector for it. If the connection is not firm, then you may need to adjust or "tighten" the connector.

Worst case scenario is the gauge reads true and chaos has ensued... should be evident with your oil change intervals for break-in.
__________________
3/S Street Tuner San Diego's Panda VR-4 - fully gutted w/ lots of deletes! 3094lbs as of 7/2/19

'10 EVO X SE - AEM WMI, COBB SF, K&N UICP, Tomei Titanium CBE - 300//350 on 91+Meth
'04 EVO VIII SSL - CBRD BBK Full turbo, full support, lots of suspension - 350 on Pump-E85
'92 VR-4 - Panda v.3 build - Fully built, AEM EMS S2, MHI EVO3 16G's, and Pump-E85 (for now)
"There are no secrets better kept than the secrets that everybody guesses."
bboyalan is online now   Reply With Quote
 
Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 11:18 AM.



Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.