motor issues and electrical issues. - Page 3 - 3000GT/Stealth International Message Center
3000GT/Stealth International 3000GT/Stealth International
 

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   3000GT/Stealth International Message Center > Regional Discussions > Chapters > DFW3S - NT3S - H3S

3SI.org is the premier Mitsubishi 3000GT Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 04-17-2012, 07:39 PM   #21 (permalink)
shade tree mechanic
 
skrub's Avatar
 
Join Date: Feb 2012
Location: Conroe,TX.
Drives: 92 VR4
skrub is an unknown quantity at this point
Feedback Score: 6 reviews
Default Re: motor issues and electrical issues. UPDATE

update on the battery drain, well today i took my alt and battery had it tested on the fancy machine and the showed me my alt was fine, putting out over 14v and diodes where fine. also had them test battery with another fancy machine battery came back a ok. So when me and my son where putting the alt back on and I hooked up the battery I noticed it didnt make as big of a arch spark like it usually does. so I went to go start my car and noticed I didnt have the ecu hooked up, so I thought hmmm. so I disconnected the negative battery cable hooked up the test light and did the test light test. I unpluged the ecu and noticed my light got dim, so then I disconnect the o2 sensor thats right by the ecu and my light went off all the way.

So I guess what IM sayin is my ecu and 02 sensor are screwed..... right? let me know what ya think of my findings. I did do all the fuses and relays with the test light and none made the light go off just ecu and o2 sensor.
__________________

RS-R lowering springs,Ross 9:1 forged pistons bored 20 over,fidanza cam gears,Stillen downpipe,M2 exhaust cat back,adjustable rear upper control arms,3SX stock size aluminum crank pully,Maximal solid mounts,and still adding on.
skrub is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-17-2012, 10:04 PM   #22 (permalink)
shade tree mechanic
 
skrub's Avatar
 
Join Date: Feb 2012
Location: Conroe,TX.
Drives: 92 VR4
skrub is an unknown quantity at this point
Feedback Score: 6 reviews
Default Re: motor issues and electrical issues.

ok here is a couple pics of my ecu. what do ya think?
this is i belive is a diode

this im not sure but looks like cap is leaking on the bottom


lets get some input on what you think.
skrub is offline   Reply With Quote Quick reply to this message
Old 04-17-2012, 10:27 PM   #23 (permalink)
Forum Member
 
Join Date: Jul 2009
Location: Killingworth,CT
Drives: 94 VR4, AWD Talon
Tsiturbomightym is an unknown quantity at this point
Feedback Score: 2 reviews
Default Re: motor issues and electrical issues.

Smell like fish? Keep it flat and have it recapped (new capacitors) and have that resistor replaced.
Tsiturbomightym is offline   Reply With Quote Quick reply to this message
Old 04-17-2012, 10:39 PM   #24 (permalink)
shade tree mechanic
 
skrub's Avatar
 
Join Date: Feb 2012
Location: Conroe,TX.
Drives: 92 VR4
skrub is an unknown quantity at this point
Feedback Score: 6 reviews
Default Re: motor issues and electrical issues.

Quote:
Originally Posted by Tsiturbomightym View Post
Smell like fish? Keep it flat and have it recapped (new capacitors) and have that resistor replaced.

havent smelt it yet but I can do the caps my self, pretty good at fixing them, but I just need to know what size diode that is blown.
skrub is offline   Reply With Quote Quick reply to this message
Old 04-17-2012, 11:38 PM   #25 (permalink)
Forum Member
 
TheWeav's Avatar
 
Join Date: Sep 2010
Location: Phoenix AZ
Drives: '91 VR4 / '11 Sonata
TheWeav is an unknown quantity at this point
Feedback Score: 5 reviews
Default Re: motor issues and electrical issues.

If you can't find them or find specific sizes, 3SX sells them as a set.

ECU CAPS Capacitors SET*-*Mitsubishi 3000GT*/*Dodge Stealth Parts
TheWeav is offline   Reply With Quote Quick reply to this message
Old 04-19-2012, 10:03 AM   #26 (permalink)
Paid Member
 
GTwizard's Avatar
 
Join Date: Jul 2008
Location: East of Dallas TX.
Drives: Mitsubishi
GTwizard Level 1GTwizard Level 1
Feedback Score: 5 reviews
Default Re: motor issues and electrical issues.

Caps are not going to correct the issues with that board. That board has so much acid on it I know it is beyond a "cap replacement" repair. Sent it to AVpro for repairs. They will replace the other 4 sections that have been destroyed by the acid.
__________________
Mods
OBX long tube headers, Flow master single 3" in with dual 2.5 outs. VR4 runners with 2 liter plenum, port matched lower intake, stage 3 or better race preped heads with 1 mm oversize Rev valves, Rev race dual springs and Rev keepers, Delta/HKS 272 cams, 3SX adjustable cam gears, 3.0 Cobra Mustang Throttle body, 3.0 LT1 maft and Maftranslater gen II, Alum. Flywheel, Spec stage 5 clutch, VR4 injectors, Wizard wires, Unorthadox under drive. IPS fuel rails w/adj FPR, Fuel loop, Walboro 255 hot wired, Hot wired single fan. Short shifter, Battery relocate. EBC front slotted rotors, EBC Yellow stuff Pads, 3SX SST brake lines, sway bars, springs.
No IAC, NO AC, NO extra weight, VR4 ECU as of NG2011. Still 10 to 1 slugs, Nitto NT05 Comptition Road Course Racing tires. Magan coil overs, 3sx adjustable rear links.
http://www.youtube.com/watch?v=2s0I3tnGGmg[/url]
1st place fastest NA - TXG 2012. 1ST place highest hp NA-240 FWHP TXG-2012. 1st place fastest NA - Drag - TXG 11 98mph, 1st place quickest NA - drags 14.773, 1st place Dyno - TXG11 229 FWHP & 236 tq, 2ND place Auto cross NA C/S- NG2011, 1ST place NA dyno - TX gathering 2010 - 229 FWHP & 199 tq, 1st place Fastest NA - TXG 2010 - 98.3 trap, 1st Place quickest NA - TXG 2010 - 14.680, 2ND place 1/4 at NG10, best NA time NG10 - 14.932- no traction, 2ND place 1/4 at NG09,
2ND place Autocross NG09
GTwizard is offline   Reply With Quote Quick reply to this message
Old 04-19-2012, 01:29 PM   #27 (permalink)
shade tree mechanic
 
skrub's Avatar
 
Join Date: Feb 2012
Location: Conroe,TX.
Drives: 92 VR4
skrub is an unknown quantity at this point
Feedback Score: 6 reviews
Default Re: motor issues and electrical issues.

Well the sad thing is this is what is causing my battery to go dead over night, but the car still runs. So after I move at the end of the month I'm going to send it off to get fixed.
skrub is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  3000GT/Stealth International Message Center > Regional Discussions > Chapters > DFW3S - NT3S - H3S

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the 3000GT/Stealth International Message Center forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Free email addresses do not work(yahoo, hotmail, gmail,...)
We are currently being blocked by AOL so any AOL based address may not work(aol.com, aim.com, netscape.net, cs.com)
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 01:31 AM.




Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Search Engine Optimization by vBSEO 3.3.2