N/A Bogging+Surging Issue - Page 2 - 3000GT/Stealth International Message Center
3000GT/Stealth International 3000GT/Stealth International
 

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   3000GT/Stealth International Message Center > Modifications and Technical Support > Engine - Non-Turbo

3SI.org is the premier Mitsubishi 3000GT Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 11-25-2012, 03:50 PM   #11 (permalink)
Paid Member
 
GTwizard's Avatar
 
Join Date: Jul 2008
Location: East of Dallas TX.
Drives: Mitsubishi
GTwizard Level 1GTwizard Level 1
Feedback Score: 5 reviews
Default Re: N/A Bogging+Surging Issue

I am sorry. When you said the motor was flooded, I freakenassumed with fuel. LOL.
Flooded here means way too much fuel. Water being sucked in is called "Hydro locked".
That will do it for sure. I have seen rods snap from hydro lock. I know you did not call me an ass. LOL. That we me that did that. My goalios always to get others to read, and most time my resonces are for all the others reading as well as the OP. I always keep my manual at hand. If you guy can not get a grip on some of your issues, make sure he has excess to the manaul. Anything that he has trouble finding in the manual, I can most likely help with. Although my post seem a little off the wall some times, I really am here to help.
__________________
Mods
OBX long tube headers, Flow master single 3" in with dual 2.5 outs. VR4 runners with 2 liter plenum, port matched lower intake, stage 3 or better race preped heads with 1 mm oversize Rev valves, Rev race dual springs and Rev keepers, Delta/HKS 272 cams, 3SX adjustable cam gears, 3.0 Cobra Mustang Throttle body, 3.0 LT1 maft and Maftranslater gen II, Alum. Flywheel, Spec stage 5 clutch, VR4 injectors, Wizard wires, Unorthadox under drive. IPS fuel rails w/adj FPR, Fuel loop, Walboro 255 hot wired, Hot wired single fan. Short shifter, Battery relocate. EBC front slotted rotors, EBC Yellow stuff Pads, 3SX SST brake lines, sway bars, springs.
No IAC, NO AC, NO extra weight, VR4 ECU as of NG2011. Still 10 to 1 slugs, Nitto NT05 Comptition Road Course Racing tires. Magan coil overs, 3sx adjustable rear links.
http://www.youtube.com/watch?v=2s0I3tnGGmg[/url]
1st place fastest NA - TXG 2012. 1ST place highest hp NA-240 FWHP TXG-2012. 1st place fastest NA - Drag - TXG 11 98mph, 1st place quickest NA - drags 14.773, 1st place Dyno - TXG11 229 FWHP & 236 tq, 2ND place Auto cross NA C/S- NG2011, 1ST place NA dyno - TX gathering 2010 - 229 FWHP & 199 tq, 1st place Fastest NA - TXG 2010 - 98.3 trap, 1st Place quickest NA - TXG 2010 - 14.680, 2ND place 1/4 at NG10, best NA time NG10 - 14.932- no traction, 2ND place 1/4 at NG09,
2ND place Autocross NG09
GTwizard is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-25-2012, 04:40 PM   #12 (permalink)
3/S owner since 2003.
 
ilian51378's Avatar
 
Join Date: Jul 2007
Location: Cayman Islands
Drives: 95' GTO ATX TT
ilian51378 is an unknown quantity at this point
Feedback Score: 6 reviews
Default Re: N/A Bogging+Surging Issue

Quote:
Originally Posted by GTwizard View Post
I am sorry. When you said the motor was flooded, I freakenassumed with fuel. LOL.
Flooded here means way too much fuel. Water being sucked in is called "Hydro locked".
That will do it for sure. I have seen rods snap from hydro lock. I know you did not call me an ass. LOL. That we me that did that. My goalios always to get others to read, and most time my resonces are for all the others reading as well as the OP. I always keep my manual at hand. If you guy can not get a grip on some of your issues, make sure he has excess to the manaul. Anything that he has trouble finding in the manual, I can most likely help with. Although my post seem a little off the wall some times, I really am here to help.
No problem buddy! It was my mistake with the wording of my original post. English is my second language and even though I am very comfortable with it, I still misuse some frases... Actually, I am not sure if the engine hydrolocked, because it was turning, but it wouldn't start. I have heard that when it hydrolocks it won't turn at all, but who knows. The fact is that it was shot. I found out that the heads were fine, but I am still to open up the bottom end and find out what went wrong... Ultimately, I will rebuild it and sell it or keep it as a spare.

By the way, I need to test the MAS, because the water went through it as well and seeing the deposits in the throttle body and the upper intake manifold, I am sure the picture won't be much different in it too... That is the first thing I am going to test, after eliminating the other things that I already replaced.
__________________

95' Mitsubishi GTO ATX - TT Conversion (15Gs), Paddle Shifters,Tein S-Tech lowering springs, 6000K HIDs, 99' rear garnish, 99' front end, R/T sail panels, Active Aero rear spoiler, Saleen wheels, halos, LED tail lights, gutted pre-cats, 3" straight pipe, straight-flow mufflers.
92' Dodge Stealth ES - SOLD!
http://www.3si.org/wiki/index.php?ti...D._Tail_Lights
http://www.3si.org/wiki/index.php?title=Paddle_Shifters
http://www.3si.org/wiki/index.php?ti...Steering_Wheel
http://www.cardomain.com/ride/3847604
http://www.cardomain.com/ride/996619
http://www.3si.org/forum/garage/1239
ilian51378 is offline   Reply With Quote Quick reply to this message
Old 11-25-2012, 06:12 PM   #13 (permalink)
Wheee! 2 wheels is fun!
 
speedy25's Avatar
 
Join Date: Dec 2006
Location: NE oHIo
Drives: Various Japanese
speedy25 Level 1speedy25 Level 1speedy25 Level 1
Feedback Score: 7 reviews
Default Re: N/A Bogging+Surging Issue

When you have water damage you have to be sure ALL the connectors are clean and making good contact.

Then you can work on components pass/fail

-SP
speedy25 is offline   Reply With Quote Quick reply to this message
Old 11-25-2012, 08:14 PM   #14 (permalink)
3/S owner since 2003.
 
ilian51378's Avatar
 
Join Date: Jul 2007
Location: Cayman Islands
Drives: 95' GTO ATX TT
ilian51378 is an unknown quantity at this point
Feedback Score: 6 reviews
Default Re: N/A Bogging+Surging Issue

Quote:
Originally Posted by speedy25 View Post
When you have water damage you have to be sure ALL the connectors are clean and making good contact.

Then you can work on components pass/fail

-SP
I have checked pretty much all of them, but it won't hurt to double check. Thanks for this tip though!
ilian51378 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  3000GT/Stealth International Message Center > Modifications and Technical Support > Engine - Non-Turbo

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the 3000GT/Stealth International Message Center forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Free email addresses do not work(yahoo, hotmail, gmail,...)
We are currently being blocked by AOL so any AOL based address may not work(aol.com, aim.com, netscape.net, cs.com)
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 06:06 AM.




Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Search Engine Optimization by vBSEO 3.3.2