Another Oil Light Post... only comes on after engine warms up - 3000GT/Stealth International Message Center
3000GT/Stealth International 3000GT/Stealth International
 

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   3000GT/Stealth International Message Center > Modifications and Technical Support > Engine - Non-Turbo

3SI.org is the premier Mitsubishi 3000GT Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 09-01-2007, 05:30 PM   #1 (permalink)
New User - Please be kind
 
Join Date: Jun 2007
Twistedreasonin is an unknown quantity at this point
Feedback Score: 0 reviews
Exclamation Another Oil Light Post... only comes on after engine warms up

94 stealth RT 90K miles

Alright, my oil light is coming on only after I have driven the car for 5 minutes. This started happening right after I had the last oil change. I had the engine rebuilt about 7K miles ago and had the oil pump swaped out about 25K miles ago. I do however have a small oil leak, and no I'm not sure where it's coming from. The filter is NOT loose and nither is the oil pan plug. No idea what's wrong.... Of course I had my oil changed at this new cheapo place with bulk oil soo...... the only thing I can think of is to up my oil to 20/50??? (yeah I know this is a temp solution, and yes i WOULD rather fix the real problem, but this is my daily driver) I was using 10/30. I guess that's it, any help would be greatly appriciated. I know a little somthing about cars, enough usually to troubleshoot and fix basic problems, but I'm not an engine rebuilder if you know what I mean. (I'd like to be, but I live in an apartment and park on the street!)
Twistedreasonin is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-01-2007, 06:16 PM   #2 (permalink)
Forum user
 
Monster Stealth's Avatar
 
Join Date: Jun 2001
Location: Fort Wayne, IN
Drives: 93 VR4 & 99 A4 1.8T
Monster Stealth Level 1Monster Stealth Level 1
Feedback Score: 42 reviews
Default Re: Another Oil Light Post... only comes on after engine warms up

What does your gauge look like at startup and idle warm? I would change that oil out for some high quality 20-40 or 20-50, and see how that goes. Have any details on the engine rebuild? What was replaced, and what brands? Do you know if you had to have the crank reground, and what brand of bearing were installed?
__________________
9B+93-13.2@108
E16G+E85...Summer 2013?


the cake is a lie
Monster Stealth is offline   Reply With Quote Quick reply to this message
Old 09-01-2007, 06:27 PM   #3 (permalink)
New User - Please be kind
 
Join Date: Jun 2007
Twistedreasonin is an unknown quantity at this point
Feedback Score: 0 reviews
Default Re: Another Oil Light Post... only comes on after engine warms up

Wait, I was wrong about the oil pump being replaced wrong pump, it was the water pump. By the way, the car has 92K miles on it.

The good for nothing crap ass oil gauge is where it has been for the past 3 years and change. At startup it goes up about to btw 1/3 and 1/2 and as it gets warm, it stays around the 1/3 mark while driving. At idle its near the floor, but it's been like that forever. Guys at the shop and on the forums all said that it's fairly normal for this car- as you know the stock gauge is crap.

Sorry, no info on the engine rebuild other than the fact it was earlier this year and it was a top end rebuild. All I remember is handing over the credit card and then bending over... it was all dark after that
Twistedreasonin is offline   Reply With Quote Quick reply to this message
Old 09-01-2007, 11:39 PM   #4 (permalink)
Forum user
 
Monster Stealth's Avatar
 
Join Date: Jun 2001
Location: Fort Wayne, IN
Drives: 93 VR4 & 99 A4 1.8T
Monster Stealth Level 1Monster Stealth Level 1
Feedback Score: 42 reviews
Default Re: Another Oil Light Post... only comes on after engine warms up

Sounds like an oil pump. First thing is to check the connections on the block and make sure they are plugged in and goo 2 go. They are on the rear of the block, up above the drivers half shaft. Then get a good oil and a little heavier weight, along with a good name brand oil filter. I recommend k&n, but OEM or Mobil 1 is just as good, or so I have heard. See where it from there. You sure as hell don't want to destroy your new engine, and I am really surprised they didn't replace the oil pump, when they pulled it???
Monster Stealth is offline   Reply With Quote Quick reply to this message
Old 09-02-2007, 03:31 AM   #5 (permalink)
New User - Please be kind
 
Join Date: Jun 2007
Twistedreasonin is an unknown quantity at this point
Feedback Score: 0 reviews
Default Re: Another Oil Light Post... only comes on after engine warms up

Alright, thanks, Iwill make use of your suggestions tomorrow. I'll speak to my mechanic on tues and find out if he replaced the pump with the rebuild- I know he's got detailed records on his computer. One question- if it was the pump, wouldn't the light be on from when I started the car, and not just after it's warmed up?
Twistedreasonin is offline   Reply With Quote Quick reply to this message
Old 09-02-2007, 07:27 AM   #6 (permalink)
Member: Burned valve club
 
cbatters's Avatar
 
Join Date: Jun 2002
Location: Stoughton, MA
Drives: 91 Stealth RT/TT
cbatters is an unknown quantity at this point
Feedback Score: 12 reviews
Default Re: Another Oil Light Post... only comes on after engine warms up

Alt suggestions:

1. Check oil presssure with a real gage

2. Replace oil pressure switch if oil pressure is OK and switch/light is coming on

3. I have never run 10W30 (10W40 in winter and 20W50 in summer)

4. I have 220K miles on original oil pump and still have great oil pressure
__________________
1991 Stealth RT/TT - Firestorm Red - 193K Miles / Original Owner
Maint: Castrol 10W40 / Mitsu Filter / Rislone
Replaced: 2X clutch / 3X brakes / 2X front rotors / 2X ABS HU / 1X NGK Plugs / 1X Ball joints / 2X Antenna mast / 1X Active exhaust cable / 1X Windshield / 1X Fuel FIlter / 1X Struts / 1X rear rotors / 1X Front Head / VSS / 1X rear wheel bearings / 1X Transfer case (warranty) / 1x Tie rod end (drivers side)
Overhauled: Starter, IAC, BISS, CV Boots
Upgrade: SilverStar Headlights / ebay "Xenon" Fog Bulbs (no more yellow!)
A/F Gauge / MAP - Electronic Boost Logging / MMCd Data Logger
Pending Projects: Steering Rack
cbatters is offline   Reply With Quote Quick reply to this message
Old 09-02-2007, 01:26 PM   #7 (permalink)
New User - Please be kind
 
Join Date: Jun 2007
Twistedreasonin is an unknown quantity at this point
Feedback Score: 0 reviews
Default Re: Another Oil Light Post... only comes on after engine warms up

Aww crap... well, I checked the wires for the oil sender, and guess what? They are covered with leaking oil from above... is that the oil pump just avove the sender unit? Also, could anyone point me in the right direction for installing an aftermarket mechanical oil pressure gauge WITHOUT the sandwich plate? I have a gauge, and just wanted to know if there was anyway I could bang this out today without ordering any other parts. Or is there any other way to check my oil pressure for the time being? I'm a noob, but I can follow directions pretty good.
Thanks

Edit:
Looked a little more in depth at where the hell the oil was coming from, and it looks like it might be coming from the oil pressure switch itself? Is that possible? Any idea what would cause that? Might this be why my oil light is coming on? (Still haven't gotten a real oil pressure reading yet)

Last edited by Twistedreasonin; 09-02-2007 at 02:45 PM.
Twistedreasonin is offline   Reply With Quote Quick reply to this message
Old 09-03-2007, 06:50 AM   #8 (permalink)
Member: Burned valve club
 
cbatters's Avatar
 
Join Date: Jun 2002
Location: Stoughton, MA
Drives: 91 Stealth RT/TT
cbatters is an unknown quantity at this point
Feedback Score: 12 reviews
Default Re: Another Oil Light Post... only comes on after engine warms up

Quote:
Originally Posted by Twistedreasonin View Post
Aww crap... well, I checked the wires for the oil sender, and guess what? They are covered with leaking oil from above... is that the oil pump just avove the sender unit? Also, could anyone point me in the right direction for installing an aftermarket mechanical oil pressure gauge WITHOUT the sandwich plate? I have a gauge, and just wanted to know if there was anyway I could bang this out today without ordering any other parts. Or is there any other way to check my oil pressure for the time being? I'm a noob, but I can follow directions pretty good.
Thanks

Edit:
Looked a little more in depth at where the hell the oil was coming from, and it looks like it might be coming from the oil pressure switch itself? Is that possible? Any idea what would cause that? Might this be why my oil light is coming on? (Still haven't gotten a real oil pressure reading yet)
Common failure mode of pressure switch. Stock gage shows oil pressure + oil light comes on + leaking from oil pressure switch = pressure switch failing.


Clint
cbatters is offline   Reply With Quote Quick reply to this message
Old 09-03-2007, 06:56 PM   #9 (permalink)
New User - Please be kind
 
Join Date: Jun 2007
Twistedreasonin is an unknown quantity at this point
Feedback Score: 0 reviews
Default Re: Another Oil Light Post... only comes on after engine warms up

Thanks, I'm replacing it tomorrow.... I was shitting bricks for a minute and praying it wasn't my oil pump.... Hope this post helps out someone else in the future!
And I'll be installing a real oil gauge next week... I use my car too much to worry about this crap stock gauge all the time.
Thanks again for the help man.

Last edited by Twistedreasonin; 09-03-2007 at 07:01 PM.
Twistedreasonin is offline   Reply With Quote Quick reply to this message
Old 09-25-2007, 11:55 PM   #10 (permalink)
New User - Please be kind
 
Join Date: Jun 2007
Twistedreasonin is an unknown quantity at this point
Feedback Score: 0 reviews
Thumbs up Re: Another Oil Light Post... only comes on after engine warms up

By the way, for anyone else who finds this- it was a faulty Oil Pressure Switch. Had the shop replace it for $40 including labor. (It took 3 seconds.)

Thanks 3si!
Twistedreasonin is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  3000GT/Stealth International Message Center > Modifications and Technical Support > Engine - Non-Turbo

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the 3000GT/Stealth International Message Center forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Free email addresses do not work(yahoo, hotmail, gmail,...)
We are currently being blocked by AOL so any AOL based address may not work(aol.com, aim.com, netscape.net, cs.com)
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 11:28 PM.




Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Search Engine Optimization by vBSEO 3.3.2