Clutch went with a snap and now nothing - 3000GT/Stealth International Message Center
3000GT/Stealth International 3000GT/Stealth International
 

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   3000GT/Stealth International Message Center > Modifications and Technical Support > Engine - Turbo

3SI.org is the premier Mitsubishi 3000GT Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 10-21-2012, 05:32 PM   #1 (permalink)
Forum Member
 
Join Date: Oct 2012
Mrhawx is an unknown quantity at this point
Feedback Score: 0 reviews
Default Clutch went with a snap and now nothing

Today I started working on the vr4 and i pushed the clutch in and half way it went with a snap and now the clutch pedal is very light and aint doing anyway?
Anyone had a similar problem?
Thanks
Mrhawx is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-21-2012, 05:43 PM   #2 (permalink)
AF Medic
 
NickS VR4's Avatar
 
Join Date: May 2004
Location: South Jersey
Drives: 01 Eclipse GT,94 VR4
NickS VR4 is an unknown quantity at this point
Feedback Score: 6 reviews
Default Re: Clutch went with a snap and now nothing

Sounds like something within the Bell Housing (Pressure Plate, Fork, TOB?) Before anything, have someone press the clutch pedal in, and see if the slave cylinder is moving the fork. Also try grabbing the fork and seeing if its moving loosely. You can start there.
__________________
Mitsubishi ASA Price List
1994 VR4 3000GT #2 - Under Restoration
2001 Eclipse GT
2005 Civic EX SE - Totalled
1994 VR4 3000GT - Sold
NickS VR4 is offline   Reply With Quote Quick reply to this message
Old 10-22-2012, 05:39 PM   #3 (permalink)
Flasher
 
TwIzTeD_3kGt's Avatar
 
Join Date: Oct 2005
Location: ROC, NY
Drives: VR4 | SL | R/T
TwIzTeD_3kGt Level 2TwIzTeD_3kGt Level 2TwIzTeD_3kGt Level 2TwIzTeD_3kGt Level 2
Feedback Score: 23 reviews
Default Re: Clutch went with a snap and now nothing

Hydraulic leak or a mechanical problem between the clutch fork and the pressure plate.
__________________

1997 Mitsubishi 3000GT VR4 - IPS 19T-L 93-Octane 20psi ~430awhp * PTE 550cc * Denso Supra Pump w/ STM Hot-wire Kit * SXP FPR@34psi * Coppers@.024 * Jester Dedd's PnP Flash ECU w/ Chrome V2 * Wiseco 8:1 +.035" * 3SX Rods * Spec 4+ * PMP FMIC w/ K&N FIPK * Montero MAF * Hallman Pro MBC * Greddy Type-S * Stillen DP w/ M2 CB * STM D2 Custom Coilovers * Maximal T-Case Brace & Solid F&R MM * AEM UEGO * Self-Tuned * 3-season DD * ~3,640lbs. Curb Weight
1993 Mitsubishi 3000GT VR4 - I'll just sneak this one in here...
1995 Mitsubishi 3000GT SL - Maximal Single-Shot Exhaust - Wife's 3-Season DD
1994 Dodge Stealth R/T - Restoration Project
TwIzTeD_3kGt is offline   Reply With Quote Quick reply to this message
Old 01-16-2013, 04:52 PM   #4 (permalink)
Forum Member
 
Join Date: Oct 2006
Location: Wilmington, DE
Drives: 2002 Subaru WRX
RelentlessVR4 is an unknown quantity at this point
Feedback Score: 4 reviews
Default Re: Clutch went with a snap and now nothing

I hate to bring up a dead thread, but I have this EXACT same problem. Except, my car still shifts normally. I visually watched the slave cylinder push the clutch release fork while someone actuated the clutch inside the car. I also checked and I am not losing any fluid.

Can someone tell me why my clutch pedal popped and is now like 10 times easier to push down then before? I called a shop and they said it was either the TOB or maybe some fingers on the clutch disk braking off. However, again, the car shifts fine and there is zero noise coming from the transmission. I realize SOMETHING happened, but...I have no idea what it could be at this point. Advice?

Thanks.
RelentlessVR4 is offline   Reply With Quote Quick reply to this message
Old 01-17-2013, 05:50 AM   #5 (permalink)
Flasher
 
TwIzTeD_3kGt's Avatar
 
Join Date: Oct 2005
Location: ROC, NY
Drives: VR4 | SL | R/T
TwIzTeD_3kGt Level 2TwIzTeD_3kGt Level 2TwIzTeD_3kGt Level 2TwIzTeD_3kGt Level 2
Feedback Score: 23 reviews
Default Re: Clutch went with a snap and now nothing

Quote:
Originally Posted by RelentlessVR4 View Post
I hate to bring up a dead thread, but I have this EXACT same problem. Except, my car still shifts normally. I visually watched the slave cylinder push the clutch release fork while someone actuated the clutch inside the car. I also checked and I am not losing any fluid.

Can someone tell me why my clutch pedal popped and is now like 10 times easier to push down then before? I called a shop and they said it was either the TOB or maybe some fingers on the clutch disk braking off. However, again, the car shifts fine and there is zero noise coming from the transmission. I realize SOMETHING happened, but...I have no idea what it could be at this point. Advice?

Thanks.
So it runs and drives fine? Sounds like the shop you called is probably on the right track. Likely a problem with the pressure plate. Pull the transmission off and find out.
TwIzTeD_3kGt is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  3000GT/Stealth International Message Center > Modifications and Technical Support > Engine - Turbo

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the 3000GT/Stealth International Message Center forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Free email addresses do not work(yahoo, hotmail, gmail,...)
We are currently being blocked by AOL so any AOL based address may not work(aol.com, aim.com, netscape.net, cs.com)
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 11:29 AM.




Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Search Engine Optimization by vBSEO 3.3.2